• Source Multi-Tool
    109 replies, posted
Source Multi-Tool is meant as a replacement to Valves Source SDK Launcher. Current features: * Launch hammer for any game or mod * customConfig, a way for you to setup hammer for mods and Garrys mod and even lets you choose what content to mount! * Launch model viewer * VPK Creator * WIP tutorial tab Images: [t]http://i.imgur.com/Zort1KT.png[/t] [t]http://i.imgur.com/2tAHvW9.png[/t] [t]http://i.imgur.com/puXTBEJ.png[/t] [t]http://i.imgur.com/BDdd85p.png[/t] Download links: [url=http://www.filedropper.com/sourcemultitool102]File Dropper[/url] [url=http://www.datafilehost.com/d/e4b9d284]DataFileHost[/url] [url=http://www.sendspace.com/file/rp0ccd]SendSpace[/url] Be sure to join the Steam Group page if you want to know right away when a new version is released and any news on it: [url]http://steamcommunity.com/groups/SourceMultiTool[/url] [B][url=http://steamcommunity.com/sharedfiles/filedetails/?id=198444877]The Guide[/url][/B] [B][url=http://steamcommunity.com/sharedfiles/filedetails/?id=198444877#183227]What is custom config?[/url][/b] [B][url=http://steamcommunity.com/sharedfiles/filedetails/?id=198444877#202790]What is VPK creator?[/url][/b] If you find a bug please post it in the group page in the bug forums section. This is so I can keep track of all the bugs in one place and people can see what is already reported. Changelog: Version 1.01: * Added model viewer support Version 1.02: * Added VPK creator * Added Blade Symphony Support * Added WIP Tutorials Tab * Fixed Portal 2 not launching * Fixed bug for user somehow not having a gameconfig.txt by default in sdk 2013 when using customConfig * Updated customConfig setup -------* Removed unneeded options -------* Users have to include HL2 now (before if you didn't it messed up sdk 2013's hammer) -------* HL2 now mounts in front of everything else to ensure nothing breaks -------* EYE support added -------* Now creates a custom folder for mounting custom assets -------* Added a button to open the custom folder Known Bugs: * Korean users might have some issues due to a character conflict * If you are one of them cool cats that uses multiple partition/drives MultiTool for the time being will only find your games that are located in same partition/drive as steam. Whats being worked on right now: A rewriting of the entire back end coding so you can use multiple partitions/drives! Going to take awhile because I was lazy and tried to take shortcuts first time! What will come after: Model compiling tools of some sort. Not sure if it's going to just take .smd's or if I want to try and delve into the idea of writing something that can use .obj's which will probably end with me crying.
Glad to see this finally come out! The gamefront link keeps saying the webpage doesn't exist when I try to download it.
[QUOTE=code_gs;42961669]Glad to see this finally come out! The gamefront link keeps saying the webpage doesn't exist when I try to download it.[/QUOTE] Just uploaded it so might take a few minutes, if it doesn't fix itself in the next hour I'll reupload somewhere else. Edit: Went ahead and added 2 more links.
neato, what language is it?
[QUOTE=KnightVista;42963697]neato, what language is it?[/QUOTE] C#
Add a ability for the hlmv and faceposer to be launched. It should only be a copy pasta to add it in right?
This is great! I'll be sure to use it :)
What a great tool! It really helps with some of the hassles I've had with mapping. :D
[QUOTE=Sally;42966570]Add a ability for the hlmv and faceposer to be launched. It should only be a copy pasta to add it in right?[/QUOTE] That's what is next on my to add list :)
Didn't you say in one of your posts that The Ship wasn't supported? What's the reason for that?
[QUOTE=code_gs;42968792]Didn't you say in one of your posts that The Ship wasn't supported? What's the reason for that?[/QUOTE] The Ship sadly uses 2006, and it's vpks aren't mountable by default for some reason.
So how do we update your program? Will it check for updates itself or will we have to uninstall the old and reinstall what you post?
Brilliant. I [I]was [/I]working on a config generator for hammer, but this seems far better. Will download and let you know what I think.
[QUOTE=KnightVista;42969422]So how do we update your program? Will it check for updates itself or will we have to uninstall the old and reinstall what you post?[/QUOTE] All you will have to do is replace the old .exe with the new one. Unfortunately don't have the funds for a server or the experience for self updating and checking. It is something I would like to add later on though.
All the novice mappers who couldn't work around the current issues should be thanking you for this.
Sneaky peak [t]http://i.imgur.com/wzyFdUe.png[/t] Btw if you want to help test out the beta builds send me a PM with a link to your steam profile. Everything seems to be working except Gmods unless you mount it through custom config... expect a release by the end of the week.
Thanks mate.
It appears the in-hammer model viewer is borked. [T]http://i.imgur.com/Tpbd4MQ.png[/T] Is there any sort of fix or will I have to wait for the next version? Also, could you possibly add support for E.Y.E: Divine Cybermancy? It kind of defeats the purpose if I still have to copy over all the files and create a sourcemod with its content before being able to map with it.
[QUOTE=samuel2213;43013794]It appears the in-hammer model viewer is borked. [T]http://i.imgur.com/Tpbd4MQ.png[/T] Is there any sort of fix or will I have to wait for the next version? Also, could you possibly add support for E.Y.E: Divine Cybermancy? It kind of defeats the purpose if I still have to copy over all the files and create a sourcemod with its content before being able to map with it.[/QUOTE] I take it this is with custom config? I've seen one other person encounter this error. What content are you mounting by chance? It seems to happen if they have certain Source mods mounted. I'm thinking the best solution I'll have to do is instead of mounting ALL source mods populate the list with them, probably won't come with this weeks update but will be moved to the top my to do list along with the following thing. I thought for some reason E.Y.E. was running on Alien Swarm branch but now that I look at it seems to be 2007. I'll go ahead and add support for it seeing as it's files are located in an easy access place and not packed up within a weird vpk like The Ship is. BTW has anyone run into an error where for some reason SDK 2013 multiplayer doesn't have a gameconfig.txt file? I've run into one person who for some reason their sdk didn't come with one.
[QUOTE=wazanator;43014146]I take it this is with custom config? I've seen one other person encounter this error. What content are you mounting by chance? It seems to happen if they have certain Source mods mounted. I'm thinking the best solution I'll have to do is instead of mounting ALL source mods populate the list with them, probably won't come with this weeks update but will be moved to the top my to do list along with the following thing. I thought for some reason E.Y.E. was running on Alien Swarm branch but now that I look at it seems to be 2007. I'll go ahead and add support for it seeing as it's files are located in an easy access place and not packed up within a weird vpk like The Ship is. BTW has anyone run into an error where for some reason SDK 2013 multiplayer doesn't have a gameconfig.txt file? I've run into one person who for some reason their sdk didn't come with one.[/QUOTE] I cleared out all my other sourcemods and created my own custom mod with the E.Y.E content, so only E.Y.E and HL2 content loads. This is how the custom content is set up [IMG]http://i.imgur.com/a6jcq1o.jpg[/IMG]
[QUOTE=samuel2213;43014383]I cleared out all my other sourcemods and created my own custom mod with the E.Y.E content, so only E.Y.E and HL2 content loads. This is how the custom content is set up [IMG]http://i.imgur.com/a6jcq1o.jpg[/IMG][/QUOTE] Thanks I'll see if I can recreate the bug using this info and hopefully fix it.
Version#: 1.01 Download links [url=http://www.filedropper.com/sourcemultitool101]File Dropper[/url] [url=http://www.datafilehost.com/d/4c0cc321]DataFileHost[/url] Changelog: Added model viewer support Still trying to solve the issue with EYE, think I've almost got it pinned down
Update! [url=http://facepunch.com/showthread.php?t=1327883&p=42961574&viewfull=1#post42961574]Please see OP for full 1.02 changelog[/url] Main changes: * VPK creator, make VPKs effortlessly. Don't worry about loose files anymore! * WIP Tutorials tab that contains links to various resources (PLEASE GIVE ME MORE TO PUT IN THERE) * Blade Symphony and EYE support added * Fixed Portal 2 launch bug
Friend of mine recommended this tool, however I currently can't open it. I took the liberty of using .NET Reflector to look how you access the source directory and it seems you grab it from the registry, but what if Source SDK is located in another library. Since Steam now allows you to define different locations / drives to install to, a lot of SSD users such as myself like to offload non-important games/tools to other drives. I was wondering if you had any use cases where your tool loads Source SDK from a different Drive / Steam Library. I'm not sure if this is the error behind why I can't seem to launch the program, but it's just my assumption. I'm running Win 8 Pro 64-Bit. [B]EDIT:[/B] Took the decompiled source, edited the get registry function to return my alternate drive's steam location (E:\Program Files (x86)\Steam), recompiled and ran. Opens like a charm. Please add steam library support. I don't know where steam stores the alternate steam library locations, as the registry just shows the standard C drive default one. Credits would be appreciated. [B]EDIT 2:[/B] Might be worth adding an extra UI on startup which asks for a steam library directory. Then you feed this in as the getRegistry value. Because I have 3 libraries I can change the return to the other steam lib install directories and get the games I have on that library. Shouldn't be too difficult.
[QUOTE=Xviper_12;43389043]Friend of mine recommended this tool, however I currently can't open it. I took the liberty of using .NET Reflector to look how you access the source directory and it seems you grab it from the registry, but what if Source SDK is located in another library. Since Steam now allows you to define different locations / drives to install to, a lot of SSD users such as myself like to offload non-important games/tools to other drives. I was wondering if you had any use cases where your tool loads Source SDK from a different Drive / Steam Library. I'm not sure if this is the error behind why I can't seem to launch the program, but it's just my assumption. I'm running Win 8 Pro 64-Bit. [B]EDIT:[/B] Took the decompiled source, edited the get registry function to return my alternate drive's steam location (E:\Program Files (x86)\Steam), recompiled and ran. Opens like a charm. Please add steam library support. I don't know where steam stores the alternate steam library locations, as the registry just shows the standard C drive default one. Credits would be appreciated. [B]EDIT 2:[/B] Might be worth adding an extra UI on startup which asks for a steam library directory. Then you feed this in as the getRegistry value. Because I have 3 libraries I can change the return to the other steam lib install directories and get the games I have on that library. Shouldn't be too difficult.[/QUOTE] Earlier version actually had a way for you to set your steam folder location but I removed it because it seemed like the use of the registry fixed the issue (at least with my test group it did). I'll go back and add it in then continue looking for a way to prevent this issue. BTW if anyone has any tutorial or communities they think should be added please post them here!
Cheers, much appreciated.
When I build maps with the "Custom Config" set up, all custom textures come out really bright and they don't seem to receive light, but all regular textures are fine. I've tried changing the vrad/vvis stuff to the same ones Ep2 uses but it didn't solve it. Any fixes? [editline]11th January 2014[/editline] [t]http://i.imgur.com/5q4rGKK.jpg[/t] Thats the problem. Taking the map into the Ep2 hammer and rendering it there doesn't produce the same problem, but it's really time consuming to do that, and I'd like to be able to edit all the L4D2 objects in the same go.
quick question about creating vpk's: Say I make one, but later want to update it, do I have to delete it and recompile a new one using the original folders/subfolders/files?
Dear wazanator, I've downloaded your Multi-Tool but it doesn't execute. :( I'm using windows 8 and have tried all of the service packs. Unfortunately that did not solve the problem. :( Could you please help me? Relpy!!! Thanks! :)
[QUOTE=Skanibani;43641241]Dear wazanator, I've downloaded your Multi-Tool but it doesn't execute. :( I'm using windows 8 and have tried all of the service packs. Unfortunately that did not solve the problem. :( Could you please help me? Relpy!!! Thanks! :)[/QUOTE] Are you running as administrator?
Sorry, you need to Log In to post a reply to this thread.