• Animations and Errors
    3 replies, posted
  • I'm having a couple of issues i was hoping someone may be able to help me with: -In my DarkRP server (Yes i know, fuck darkrp, etc.) the custom playermodels work but in the menu where you select the job their icons are errors -Some playermodels i have lack animations for the pocket and keys weapons, and just go to default position If anyone has any ideas how to fix these i would appreciate the help. Thanks in advanced.
  • Not sure about the icons that are errors, but the player models can only be fixed if you decompile them and add a couple lines to the QC. The keys swep uses the ACT_IDLE, ACT_WALK, and ACT_RUN animations I think. What you need to do is find a line that looks like this: $sequence gravgun_idle "gravgun_idle" fps 30 ACT_HL2MP_PHYSGUN_IDLE 1 or something similar and add $sequence keys_idle "gravgun_idle" fps 30 ACT_IDLE 1 PM me if you need a bit more help with that, although unless the custom model has an animation with their hands at their side you'll just have to use the gravgun animations.
  • Avatar of autokey
  • [QUOTE=Polycounter;34599885]Not sure about the icons that are errors, but the player models can only be fixed if you decompile them and add a couple lines to the QC. The keys swep uses the ACT_IDLE, ACT_WALK, and ACT_RUN animations I think. What you need to do is find a line that looks like this: $sequence gravgun_idle "gravgun_idle" fps 30 ACT_HL2MP_PHYSGUN_IDLE 1 or something similar and add $sequence keys_idle "gravgun_idle" fps 30 ACT_IDLE 1 PM me if you need a bit more help with that, although unless the custom model has an animation with their hands at their side you'll just have to use the gravgun animations.[/QUOTE] Ah yes nice advice
  • [QUOTE=autokey;34601993]Ah yes nice advice[/QUOTE] Wait you worked on Nuclear Dawn !?!