• [MMD] Touhou Model Port
    707 replies, posted
  • Glad to hear that is fine. What is the limit of Source by chance? Also, still haven't fixed my texture importing problem.
  • Sorry for the massive delay, was away for the weekend. It's not exactly an error message that pops up, it's just that when I import the model, no textures or the bones show up with the model. They usually appear all gray if it's one mesh or different color if it's multiple meshes.
  • Sorry for the double post, but this is what I mean with other models with the no texture problem. This is with the materials option left unchecked [IMG]http://i868.photobucket.com/albums/ab246/NovaxSiryx/fusionsuitnotexturenomaterial.png[/IMG] This is with the materials option checked [IMG]http://i868.photobucket.com/albums/ab246/NovaxSiryx/fusionsuitnotexturematerial.png[/IMG] Hopefully some answers might help me getting the textures to appear on the Flandre model (and future models imported this way).
  • I have no idea how to do such a thing. I shouldn't have to as all of these models have their textures uv maps and some even rigging. I don't understand why it's not importing right.
  • [QUOTE=Novax;24962131]I have no idea how to do such a thing. I shouldn't have to as all of these models have their textures uv maps and some even rigging. I don't understand why it's not importing right.[/QUOTE] Well, i'm not too sure if anyone here knows how to solve your problem at all. The next best course of action seems to be to make your own UVmap so that someone can give it a shot at making a new texture. If you do attempt such a thing, could it be possible that the UV map has something to indicate what body parts will be textured?
  • It doesn't need any new textures as I already have the texture files for all the models. They just won't show up for some reason.
  • [QUOTE=Novax;24962212]It doesn't need any new textures as I already have the texture files for all the models. They just won't show up for some reason.[/QUOTE] See if you can't convert the textures to something more manageable, such as VTF or TGA. (if you do use VTFs, use this. [url]http://developer.valvesoftware.com/wiki/3DSMax_VTF_plugin[/url][noparse])[/noparse]
  • The Flandre model's textures are already in .TGA format. I don't know about the others. I can look at that, but don't know how good that will do me.
  • Actually, what would the model look like when exported to an mdl and brought to the HL2 model viewer?
  • I don't have such things yet and won't for awhile, so that option is out too. I really need someone to help me figure out the main problem at hand.
  • If possible, i suggest you give the files to someone who's more familiar with 3dsmax to find out what exactly is wrong.
  • Port the LD2 Touhou models with the MMD ones we already got a Cirno up so... will provide models for the LD2 ones btw
  • [QUOTE=Novax;24959887]Sorry for the double post, but this is what I mean with other models with the no texture problem. This is with the materials option left unchecked [IMG]http://i868.photobucket.com/albums/ab246/NovaxSiryx/fusionsuitnotexturenomaterial.png This is with the materials option checked [IMG]http://i868.photobucket.com/albums/ab246/NovaxSiryx/fusionsuitnotexturematerial.png Hopefully some answers might help me getting the textures to appear on the Flandre model (and future models imported this way).[/QUOTE] Well first thing, where did you get that mesh from exactly? and didn't you get the textures that came along with it?
  • If we cannot find a solution to your texture problem, the most we can do is create a UV map, and post it here so someone can make new textures.
  • I got the model from the model's resource site. All the textures are with it and it even has rigging via a smd file. Now the file is an obj format so I do not know if that's the case. The Flandre model I have no idea on how to get the textures to appear as that's importing through a different model. I don't want to give up as I want these models myself to appear correctly.
  • Pass me the link to the SMD one and i'll feed it thorugh Milkshape and see if applying the textures first can help.
  • Here is the link to the Fusion Suit Samus model. Just scroll down a bit to find it. [url]http://www.models-resource.com/wii_gamecube/supersmashbros.brawl/index.html[/url]
  • It works perfectly in Milkshape, textures are already applied, the rigging is a bit crap though. Want me to export it as a 3ds and upload it for you? Edit: Uploaded it anyway - [url]http://www.mediafire.com/download.php?j7d3bdqiyrpsmad[/url] Put it in the same folder as the textures and if 3ds is anything like Milkshape it will auto apply the textures when you open it. Edit2: Are any of the other models on that page rigged?
  • Novax, not sure if you've done this, but when you import an MMD model, press Shift + T to bring up a the texture window. Highlight all of the textures, right click them, click "set path", and go to where the texture files have been stored.
  • Thank you for the upload. Unfortunately, I still have the same problem. I'm going to try one last thing. IF not, I might make a thread in the main area to see if it's still something not right on my side (which I'm guessing it is). As for the other models, some have rigging, some don't. I didn't see your post before SakuraX. However, this is getting me on the right track as it says the files are missing, but fixed and did so. I still don't have them showing up, but this is none the less helping me. I tried this only on the Fusion Suit Samus. The Flandre model is only allowing one texture in the tree to show up but still doesn't show up on the model itself Edit: Maybe a picture guide might help as stupid as that sounds.
  • If all else fails, you may have to post a new thread asking for help. If that fails, make a UV map.
  • Well, I got the Fusion Suit and Light Suit textures to finally appear thanks to a friend's help. With the help of SakuraX and my friend, I got them to appear. Apparently, I had to "Activate the Maps" for the textures to appear for some odd reason after fixing the file path. However, even using this method, I was unable to get the Flandre model to have any textures to appear. It also has trouble obtaining all of the textures it needs as well. If Vaust Kil would swing by to tell me how he did it successfully, that would help out a bit too. [IMG]http://i868.photobucket.com/albums/ab246/NovaxSiryx/fusionsuittextured.png[/IMG]
  • If you upload that one, i'll check that one for you aswell if you want (as .obj or .3ds would be best).
  • If you mean the Fusion Suit Samus model, that's the same one from before. If you mean the Flandre model, I'll have to see as I don't have an uploading source available yet. I'm also going to try that Blender plugin as backup in case I can't get things to work in 3D Max.
  • The Flandre one. Just upload it to [url=http://www.mediafire.com]MediaFire[/url] as you don't need an account or anything to upload to it.
  • Alright, I'll try. If you do get anything to work, will you teach me and such so that I can learn as well? Here is the model and textures. The format is OBJ for the model and TGA for the textures. [url]http://www.mediafire.com/?audtm59duznyl8n[/url]
  • [QUOTE=Novax;25030336]Alright, I'll try. If you do get anything to work, will you teach me and such so that I can learn as well?[/QUOTE] Sure ^^ Though I have no idea how to do the stuff I do in Milkshape in 3DSmax but I will try to help where I can :)
  • Posted link above, but in case, I'll have the link again. Flandre model [url]http://www.mediafire.com/?audtm59duznyl8n[/url]