• Can't decompile TF2 Player models AT ALL and I'm in distress
    23 replies, posted
  • So I want to decompile the Spy player model. Open up XVI32, change "IDST0" to "IDST," and decompile. Decompiler crashes. Tried with "IDST.", "IDST/" and even with "IDST0" itself. Nothing. No checkbox is checked. Decompiler is in the sourcesdk/bin/ep1/bin folder, it's version 0.5 (latest), because it doesn't run at all from the sourcesdk/bin folder. Yes, I googled. Everyone said "IDST0" to "IDST,".
  • It might just be a typo in your post, but it looks like you used IDST[B].[/B] instead of IDST[B],[/B] and try running ot from the orangebox/bin folder instead?
  • [QUOTE=Zyx;16154990]It might just be a typo in your post, but it looks like you used IDST[B].[/B] instead of IDST[B],[/B][/QUOTE] I used comma, a stop and a slash. None worked [QUOTE=Zyx;16154990]and try running ot from the orangebox/bin folder instead?[/QUOTE] "The procedure entry point Q_AppendSlash could not be located in the dynamic link library vstdlib.dll." Also, Lord Ned sent me the files, but I still wanna fix this incase I want to decompile something else.
  • IDST0 to IDSTO? I can decompile TF2 Player models just fine, if need be, I could give you whatever one you want.
  • [QUOTE=Lord Ned;16161422]Put it in sourcesdk/bin/ep1/bin, not orangebox[/QUOTE] Read the OP better [QUOTE=i_speel_good;16154823]Decompiler is in the sourcesdk/bin/ep1/bin folder[/QUOTE] [editline]03:36AM[/editline] [QUOTE=F T;16161386]IDST0 to IDSTO?[/QUOTE] Didn't work sadly. Thanks anyway!
  • Dont do that IDST thingy, but use this decomp instead: [url]http://www.filefront.com/14033171/mdldecompiler_hacked.zip/[/url] It works like a charm no matter what tf2 stuff I decompile
  • After Changing IDST0 to IDST, (in the model) it worked for me, but the animations are all fucked up D:
  • Okay, this is weird. With the hacked decompiler, I can only decompile the Pyro. Nothing else. And that's probably only because the Pyro doesn't have any facial expressions and such.
  • [QUOTE=i_speel_good;16240083]Okay, this is weird. With the hacked decompiler, I can only decompile the Pyro. Nothing else. And that's probably only because the Pyro doesn't have any facial expressions and such.[/QUOTE]Yeah, the Pyro wears a ask so he doesn't have any facial expressions. Also the TF2 player models have different face designs than the HL2 ones, but I don't know if that's what's wrong.
  • I have the same problem with the L4D models, I can start the decompiling if I change them from IDST1 to IDST, but it crashes and only gives me a .vta file (the expressions file).
  • [QUOTE=i_speel_good;17280332]Yeah, L4D models only work with an older decompiler.[/QUOTE] Do they, which decompiler do you need, I've tried StudioCompiler and MdlDecompiler and neither of those worked.
  • I've had the exact same problem. I've used the hacked decompiler, edited my gameinfo.txt file to ignore the ToolsAppID issue, etc. I can get the decompiler to tell me it's loaded a model, as long as I manually type in the actual path to the .mdl file, (trying to use the browse feature crashes the decompiler). When I actually hit "Extract", the decompiler simply crashes. I had previously extracted everything from the TF2 set about 6 months ago, but just recently realized that the .VTA for the engineer didn't successfully get extracted. (The .vta's for all the other characters came out just fine). I don't suppose anybody has a mdldecompiler_expressions.vta for the engineer out there that they'd be willing to send me do they???
  • Well, so why don't you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can't be decompiled with facial animations).
  • [QUOTE=ferdam;17323616]Well, so why don't you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can't be decompiled with facial animations).[/QUOTE] Really? Thats the only part I can get when decompiling them O.o
  • [QUOTE=ferdam;17323616]Well, so why don't you try MDLDecompiler 0.4 ? As you said, only Pyro could be decompiled because he has no facial expressions, and MDLD 0.4 worked on L4D models (L4D models have the problem that can't be decompiled with facial animations).[/QUOTE] I've already tried 3 versions (newest, hacked, 0.4) with and without IDST changing
  • The hacked mdldecompiler works for me on any model...no matter if it is ep1 or ep2 engine or a hq model from FakeFactory mod.
  • I have this problem after i install Microsoft Visual Studio C++... Befor i did, i might decompile Tf2 models without any trouble... Now i want decompile PYRO.mdl and its crashed after starting (I press EXTRACT then its wrote me "LOADED model/...mdl etc.") Then Just-in-time debuggin'... i disable it by cleaning LOCAL_ Regedit files.. and just turned off it in Visual Studio.. And now its just no errors at all.. but decompiler still crash here... HACKED version doesnt help too.. But... If i remember correctly.. This will fix self... dont know why.. maybe updates or something else like installing another soft... If any one know a cure of it... please help. Maybe some one already fix it. I hope. Thanks.
  • [QUOTE=Stanislav SoDL;18815101]I have this problem after i install Microsoft Visual Studio C++... Befor i did, i might decompile Tf2 models without any trouble... Now i want decompile PYRO.mdl and its crashed after starting (I press EXTRACT then its wrote me "LOADED model/...mdl etc.") Then Just-in-time debuggin'... i disable it by cleaning LOCAL_ Regedit files.. and just turned off it in Visual Studio.. And now its just no errors at all.. but decompiler still crash here... HACKED version doesnt help too.. But... If i remember correctly.. This will fix self... dont know why.. maybe updates or something else like installing another soft... If any one know a cure of it... please help. Maybe some one already fix it. I hope. Thanks.[/QUOTE] Models SMD's are included in the SDK. If you don't see them, open up the SDK and press refresh content.