• [solved]"accurate / tight" Phymodel ?
    20 replies, posted
hey guys, its me again. i was trying to create models for L4D2, it works, but the phymodel is weird. here is a image to explain my problem: [IMG]http://i.imgur.com/ygw0oL1.png[/IMG] my physmodel is just a model wich goes around all edges, but it doesnt take a curve in also, why is valves physmodel red? i'd happy if someone could help me out ~Funreal
Post your .qc, I assume the problem is either there or in you collision reference model.
my qc [QUOTE] $modelname "Absolute Zero\test.mdl" $staticprop $bodygroup "Body" { studio "test.smd" } $cdmaterials "models\Absolute Zero\" $texturegroup "skinfamilies" { { "flatbed_cart01.vmt" } } // Model uses material "flatbed_cart01.vmt" $surfaceprop "metal" $illumposition 0.018 1.423 22.309 $bbox -71.774 -57.126 -0.302 69.45 57.433 45.293 $cbox 0 0 0 0 0 0 // The hitbox info below was automatically generated when compiled because no hitbox info was provided. $hboxset "default" $hbox 0 "static_prop" -71.742104 -57.096432 -0.301838 68.896072 57.132633 44.918839 $sequence "idle" "test.smd" { fps 30 } $collisionmodel "test.smd" { $concave $mass 0 $maxconvexpieces 150 } $collisionjoints "test.smd" { $mass 0 $inertia 0 $damping 0 $rotdamping 0 $rootbone "" $maxconvexpieces 150 } [/QUOTE] ps: the materials are wrong, i just wanted to get that phymodel to work, but i failed edit: the model, is the colision model of valves police car
Why do you have both $collisionmodel and $collisionjoints? $collisionjoints is for models with several bones (aka ragdolls), I think removing the lines from {$collisionjoints"test.smd"} on down should fix your problem.
not really. the yellow lines are now red, but the shape is the same
Well, the $concave command should be preventing the shrinkwrapping. Does the model have more than one bone?
it has only one bone, and removing the $concave comment did not help
Try replacing your lines about collision with this: [code] $collisionmodel "test.smd" { $concave $mass 0 } [/code] I've had the compiler complain about my formating before and the $maxconvexpieces command isn't for somethign as simple as this. See [url=https://developer.valvesoftware.com/wiki/$collisionmodel]here[/url] for more information about the options you can use with $collisionmodel. o, and next tim you post your .qc, post it with the[noparse][code]INSERT TEXT HERE[/code][/noparse] so others may copy it.
that did not help me either. any i tried every possible thing with those commands, but no luck btw, you can copy quotes
Well it isn't letting me copy quotes for some reason. That code should have solved your problem, but here is some more I just pulled from a decompiled model, give it a shot. [code] $collisionmodel "test.smd" { $concave $mass 1000.0 $inertia 1.00 $damping 0.00 $rotdamping 0.00 } [/code] If that doesn't work, you could send me your .smds and I could play around with it until it worked.
Didn't work either. I already tried everything but it doesn't work. here is the smd file, its just a lowpoly model of something: [url]http://filesmelt.com/dl/test16.rar[/url] but i want to figure it out, because it never works
Would you mind sending me the police car's .smd too?
i didnt use the police car smd's i only used that smd i gave you
Okay, I see what's going on here, its an issue with smoothgroups in the .smd
that model IS the model i want to give collision to. i just want to get working collision on any kind of object. :s
Oh, okay, misunderstood the problem. the problem is with the model's geometry is all being assigned to one smooth group, so it smooths it all together on compile.
the model has the same shoothing group, at least, thats what my program says. edit: spliting all the groups to different smoothing groups didnt help
When I split the groups up, it helped, but my compiler is complaining about some 2d geometry, which makes it spaz out and shrinkwrap the whole thing. So there is probibly a split vertice or a plane that isn't attached where it's supposed to be.
and how can i do that? edit: it worked :D click for 100% size [URL=http://i.imgur.com/AZdRT8x.png][IMG]http://i.imgur.com/AZdRT8xl.png[/IMG][/URL]
So how did you fix it/what was wrong?
fot the TUMTaRA logo, every letter is in an seperate group, and each of them also has a own smoothing group
Sorry, you need to Log In to post a reply to this thread.