• gmod_src: will no longer try to cache more models than model..
    17 replies, posted
[B]Revision 735[/B] [INDENT]will no longer try to cache more models than modelprecache will hold Added sv_maxprecachedmodels to control the number of precachable models - which may help some servers that get overflow errors on join if they set it low like 512 etc.. Cleaned up model filenames, so that it doesn't count these as different models: models/something/blah.mdl models\something/blah.mdl models\something//blah.mdl etc.. [/INDENT][B]Changed Files:[/B] [LIST] [*]trunk/src_garrysmod/game/server/baseentity.cpp [*]trunk/src_garrysmod/game/server/baseentity.h [*]trunk/src_garrysmod/garrysmod/Objects/lua_entity_cl.cpp [/LIST] Committed By [B]Garry Newman[/B]
Does this mean modelprecache crashes are finally a thing of the past?
Amazing. Mind checking your email for my reply to your last message.
Excellent. Incidentally, what happens now when the limit is passed?
No new models can be loaded
What would happen then for instance if I spawned a prop physics and set it's model to an uncached one once the limit was up. Would it silently fail? Throw a lua error? Throw a red engine error? Call the NoMoreModelsCanBePrecached hook? Reload the map? Clear the cache table and start again?
Probably an error model. If you tried to spawn one using GMod's spawn menu it would just silently fail.
This update has some really awsome changes :golfclap: Release it early :3: (or atleast upload it to gmodgame)
It is already on gmodgame.
Anyone tested it? So we don't get surprises like not being able to use any models.
I'd like to test, but the SVN will not update for me. (It used to, but suddenly will not) Screenshot: [url]http://img241.imageshack.us/img241/5395/63039903.png[/url] Every other SVN works fine. The GMod Beta SVN seems to be updating at a rate of about 3KB/s. Is this a problem at my end? Or is it a problem with the SVN?
Get a proper SVN client.
"1217/ - prop_physics: UTIL_SetModel: coudn't precache: models/props_wasteland/controlroom_storagecloset001a.mdl" Will this svn fix this issue?
I think you'll find that is the limit being hit.
But the command isn't available ingame. Also, it still crashes once that limit is hit.
4 weeks ago, ya'll probably should have complained back then. That's why this SVN exists.
It worked 4 weeks ago, was awesome. I loved you 4 weeks ago, now I just want to have a quick affair with you ;).
Sorry, you need to Log In to post a reply to this thread.