• My laptop lags only Source Games
    22 replies, posted
So my laptop's specs are as follows: Processor: Intel(R) Core i7-6500U CPU @ 2.50GHz 2.59 GHz Installed RAM: 12.0 GB (11.9 GB usable) And it says it has a Nvidia Geforce 940Mx Graphics card. I've also checked the Task Manager while i'm in game, and it says it's the game I think. Like it's the most infuriating thing. I turn on Half Life 2 and the audio just starts ripping to shit and the frames go from 120 or higher to 5 frames for about 10 seconds then it goes back up for about 30 seconds, then it goes to shit again. It does this for CS:GO too, I haven't tested other source games, but these two games really just drop. I had a 2007 laptop with a pentium that ran Half Life 2 better than this shit, it makes me seriously mad. Garry's Mod runs fine though. Like I don't know if this is a hardware problem or a software problem. I've looked for a solution, but still can't find one.
Firstly I'd make sure you have the latest Windows updates, and your laptop manufacturer may have bundled an update application with your laptop, so check that as well. If that doesn't work, then check the graphics settings on the game, try toggling multicore rendering, and make sure there's no power saving settings on
Sounds like thermal throttling. Try typing "fps_max 60" in the console.
CSGO and Portal2 in particular have an option for Laptop power savings, make sure it’s off.
[QUOTE=djjkxbox;52651372]Firstly I'd make sure you have the latest Windows updates, and your laptop manufacturer may have bundled an update application with your laptop, so check that as well. If that doesn't work, then check the graphics settings on the game, try toggling multicore rendering, and make sure there's no power saving settings on[/QUOTE] Alright so I disabled multicore rendering, it's not that. I have the latest update. It keeps going into power saving mode for some reason, and I know this because the screen keeps going dim every once and awhile. I have it disabled and it still keeps going to it. I'm fairly certain this is the problem. Yeah this is it. Or at least i'm pretty sure. The only problem I think I have now is that the screen keeps getting dark, and it's not the adaptive brightness, because i'm sure that's off. Edit: Okay so I don't have power saving mode on, and the frames are dropping again. I'm doing this in Half Life 2 Btw. Whenever I alt-tab out of game to the power settings the screen starts getting brighter. It's like what it wants to do whenever it's in power saving mode. I might try that command now. (I tried it, it doesn't do anything for HL2)
[QUOTE=Samson0722;52651568]Alright so I disabled multicore rendering, it's not that. I have the latest update. It keeps going into power saving mode for some reason, and I know this because the screen keeps going dim every once and awhile. I have it disabled and it still keeps going to it. I'm fairly certain this is the problem. Yeah this is it. Or at least i'm pretty sure. The only problem I think I have now is that the screen keeps getting dark, and it's not the adaptive brightness, because i'm sure that's off. Edit: Okay so I don't have power saving mode on, and the frames are dropping again. I'm doing this in Half Life 2 Btw. Whenever I alt-tab out of game to the power settings the screen starts getting brighter. It's like what it wants to do whenever it's in power saving mode. I might try that command now. (I tried it, it doesn't do anything for HL2)[/QUOTE] Have you checked your laptops power options? Make sure that's set as Performance otherwise it'll force you to use the Intel HD Graphics rather than the GPU
[QUOTE=Lebofly;52651916]Have you checked your laptops power options? Make sure that's set as Performance otherwise it'll force you to use the Intel HD Graphics rather than the GPU[/QUOTE] High Performance right? Also everytime I open the power options screen, the screen gradually starts to get much brighter. Also it doesn't lag as frequently on recommended, but it still does occasionally.
I would try setting to run on the Intel GPU instead. You may be surprised.
I mean how can you tell which one it's running on?
[QUOTE=Samson0722;52652074]I mean how can you tell which one it's running on?[/QUOTE] [url]https://www.techpowerup.com/gpuz/[/url] Go onto the sensors tab and view the usage
Make sure you have latest Nvidia drivers and that Source games are set to use the dedicated card and not iGPU. [editline]6th September 2017[/editline] In GeForce settings, that is.
Yeah it's running the 940Mx I mean shouldn't I be taking advantage of this graphics card? Or will it run better with Intel graphics? Also couldn't I set Intel Graphics to run on specific games or do I need to manually change it each time I want to play a source game? How would I change the GPU? Also putting the power settings on High Performance doesn't change the fact that it goes from 200 fps to like 5 (I misremembered in the OP) I've looked at other threads on Toms Hardware, and I've seen similar answers to the ones in this thread. None of them have really worked for me. I mean hopefully I can get this fixed. Just in case i'm going to reinstall all of the drivers. Edit: All right I reinstalled the drivers and booted up ravenholm, and at first it seemed like I was an idiot, but over time it started to lag. First one was like 5 minutes in, then it started to get more and more frequent. I don't know if it's the graphics card or what.
[QUOTE=Samson0722;52652136]Yeah it's running the 940Mx I mean shouldn't I be taking advantage of this graphics card? Or will it run better with Intel graphics? Also couldn't I set Intel Graphics to run on specific games or do I need to manually change it each time I want to play a source game? How would I change the GPU? Also putting the power settings on High Performance doesn't change the fact that it goes from 200 fps to like 5 (I misremembered in the OP) I've looked at other threads on Toms Hardware, and I've seen similar answers to the ones in this thread. None of them have really worked for me. I mean hopefully I can get this fixed. Just in case i'm going to reinstall all of the drivers. Edit: All right I reinstalled the drivers and booted up ravenholm, and at first it seemed like I was an idiot, but over time it started to lag. First one was like 5 minutes in, then it started to get more and more frequent. I don't know if it's the graphics card or what.[/QUOTE] Keep an eye out on your temperatures, this sounds like a overheat problem (perf degrades overtime from thee previous idle period). You can use: [url=https://www.hwinfo.com/]HWInfo[/url] [url=http://www.almico.com/speedfan.php]SpeedFan[/url]
[QUOTE=Richard Simmons;52652510]Keep an eye out on your temperatures, this sounds like a overheat problem (perf degrades overtime from thee previous idle period). You can use: [url=https://www.hwinfo.com/]HWInfo[/url] [url=http://www.almico.com/speedfan.php]SpeedFan[/url][/QUOTE] Yeah but if it was overheating, wouldn't it do it on other games? Insurgency runs fine, Garry's Mod runs fine, Outlast runs at a steady framerate. Also, the audio tears are the exact same as the ones that happen when I simply unplug the laptop. Could it be my charger? This pops up every time I plug it in, so i'm fairly certain this could be it. [IMG]https://image.ibb.co/ns6fEF/Capture.png[/IMG] Okay is this just them sticking me with a "smart adapter" so I have to go out and buy a "Higher performance adapter"? Edit: Alright now it's starting to rip audio on Youtube and lag when it's unplugged. What the hell.
Could very well be the charger, it's flat out saying HP throttles performance with the charger that you're using. Honestly i'd reinstall windows without the HP bloatware (Or you can uninstall every HP app) be cautious though if you do uninstall the apps your laptop with continue to use high performance settings (Unless you change it to balanced/power saver when not gaming or not plugged into a charger) which will affect charging speeds (Battery usage is faster than it can charge).
[QUOTE=Samson0722;52652136]Yeah it's running the 940Mx I mean shouldn't I be taking advantage of this graphics card? Or will it run better with Intel graphics? Also couldn't I set Intel Graphics to run on specific games or do I need to manually change it each time I want to play a source game? How would I change the GPU? [/QUOTE] You should obviously use the dedicated GPU for everything performance critical There should be specific power options in the Nvidia control panel, make sure HL2.exe is set to 'maximum performance', otherwise it's possible that it's using the iGPU instead, laptops can be real wonky like that. To be honest though, even the iGPU should run it much, much better than that, the HD 520 being a lot faster than any GPU on the market in 2005, so it still sounds like throttling to me
[QUOTE=Rixxz2;52670311]You should obviously use the dedicated GPU for everything performance critical There should be specific power options in the Nvidia control panel, make sure HL2.exe is set to 'maximum performance', otherwise it's possible that it's using the iGPU instead, laptops can be real wonky like that. To be honest though, even the iGPU should run it much, much better than that, the HD 520 being a lot faster than any GPU on the market in 2005, so it still sounds like throttling to me[/QUOTE] Source has issues with Nvidia Optimus. You may well find it performs better on the integrated, not dedicated GPU, and this may well be the issue at hand.
try using this as a launch option, it fixed all my optimus problems with source a few years ago. -force_vendor_id 0x10DE -force_device_id 0x1180
So it turns out it's not just source games, and it's my computer every time the battery gets low, or it's unplugged. It runs fine now as long as it has a full battery and is plugged up, but whenever I unplug it, the audio rips to hell, and when it gets low on battery it rips as well.
Windows has many default settings that reduce cpu speed and such when the laptop is on battery.
I'd say change your windows power settings to high performance when plugged in.
So my laptop still does this. After about 3 games of CSGO it starts lagging and I have to wait for the laptop to be fully charged again which takes 3 hours. The laptop lags when it gets halfway depleted of battery and only certain games deplete the battery. It's fucking annoying. Also this laptop came refurbished, I don't know if that helps.
Source has 'Laptop Power settings' which will throttle the game, make sure they are off recent Windows updates have allowed users to select which GPU a program uses on systems with more than one GPU.....are Source games using the Intel graphics and not the nVidia GPU? the 940MX definitely isn't the best GPU, don't expect miracles but it *should* be able to handle Source.
Sorry, you need to Log In to post a reply to this thread.