• iPod and Ubuntu
    30 replies, posted
So I want to load songs from my laptop (Ubuntu 11.10) onto my iPod Nano (3rd generation 4GB), but whenever I connect it I can't do anything to it. It shows up on media players (Banshee, Rhythmbox, Amarok) and such, and I'm able to copy songs off of it just fine, but I can't put songs [I]onto[/I] it.
I think that would require the iTunes libraries, but I don't think they exist as linux libraries.
You can try pwntunes, but i'm not sure if it is compatible with linux
This might help [url]http://ubuntuforums.org/showthread.php?t=1471018[/url] Sorry didn't see but this is apps only.
Try it as Root. Guaranteed success.
I'm pretty new to Linux, so how would I do this? Sorry if I sound like a dumbass, hahaha
Stick "sudo" in front of a command to run it as root. Root is the main, administrative user on Linux. Example: passwd - Change your password sudo passwd - Change root's password, because you're now running the command as root.
So I tried "sudo banshee" to open up Banshee as root, but then it doesn't detect the iPod as being connected.
hello, it will work either with rythmbox or gtkpod (both work) rythmbox is another media player, to install: [code] sudo apt-get install rhythmbox [/code] gtkpod is especially for ipods (but a little confusing), to install: [code] sudo apt-get install gtkpod [/code] btw, when you plug it in the pc does it detect as an ipod?
I have both Rhythmbox and Gtkpod, but Gtkpod doesn't want to work with my .m4a files for some reason. My system always recognizes the iPod whenever I plug it in, but none of my programs do when I run them as root. [editline]20th February 2012[/editline] Also whenever I try to use Gtkpod with this iPod, it gives me this notice: [quote]Import Repository Errors Errors created during repository import Extended info will not be used.[/quote]
have you installed codecs?: [code] sudo apt-get install ubuntu-restricted-extras [/code]
I already have, yes.
intstall this: [code] sudo apt-get install gtkpod-aac [/code] see if that helps
It gave me this: [code]sudo apt-get install gtkpod-aac Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package gtkpod-aac [/code]
hmpf. seems to be a bug in the latest stable, try the beta: [code] sudo apt-get-repository ppa:forage/gtkpod sudo apt-get update sudo apt-get install gtkpod [/code]
[code]sudo: apt-get-repository: command not found[/code]
ugh. typo, sorry: [code] sudo add-apt-repository ppa:forage/gtkpod sudo apt-get update sudo apt-get install gtkpod [/code]
It still won't recognize the .m4a files. Gah. [editline]21st February 2012[/editline] I don't know if this is relevant, but when I try running Banshee as root I get this in the terminal: [code][Info 16:01:58.333] AppleDeviceSource is ignoring unmounted volume floppy0[/code]
do this: [code] sudo apt-get install mp4v2 [/code] also check your plugin in gtkpod: edit > Preferences
Unable to locate package. D:
I'm out of ideas. make sure you have all the codecs installed. [code] sudo apt-get install ubuntu-restricted-extras [/code] check if video or codec plugins are checked in gtkpod (edit > preferences)
I did some reading around and someone on the Ubuntu forums said that the Natty version of gtkpod works fine with m4a files. Is it possible to use that?
Not on Ubuntu atm, try: [code] sudo apt-get install gtkpod sudo apt-get-repository -r ppa:forage/gtkpod sudo apt-get update sudo apt-get install pkg=1.0.0 gtkpod [/code]
E: Unable to locate package pkg
I don't know how to do this in ubuntu: [url]http://packages.ubuntu.com/natty/gtkpod[/url]
Just install GTKpod from PPA.
[QUOTE=P320;34827530]Just install GTKpod from PPA.[/QUOTE] Tried that, didn't work.
When I try syncing with Amarok, I get this notice: [code]Could not write to: /media/[really long serial number]/iPod_Control/Music/F05/kpod0319031.mp4[/code] [editline]24th February 2012[/editline] Also, I tried syncing an .mp3 onto the iPod via gtkpod and got this: [code]Transfer of 'Renob, Nevada' failed. Error opening '/media/95828af9-0fd4-3caa-b6d4-c8296caf3d5f/iPod_Control/Music/F01/libgpod536653.mp3' for writing (Read-only file system). [/code]
were you using your ipod on a mac before this? Try reformatting it under windows.
[QUOTE=pygar;34857394]were you using your ipod on a mac before this? Try reformatting it under windows.[/QUOTE] OMG, that's probably it. I doubt anybody thinks about that, but Linux still only has partial HFS+ support.
Sorry, you need to Log In to post a reply to this thread.