• DD-WRT: DHCP refuses to work with Windows clients
    5 replies, posted
So I've installed DD-WRT (v3.0-r36079) on my Linksys WRT1900ACS v2. The problem is that none of my Windows machines receive any addresses, and instead just revert to 169.254.150.34 /16, so as of right now I'm forced to configure the addresses manually. The weird thing is that my Linux machines connects to it just fine, as does my iPhone. DD-WRT config view: https://i.imgur.com/qJRjfgc.png Any help is greatly appreciated
Yep, they're set to obtain them automatically. I just tried connecting my cheapo old Netgear router+switch, and boom, everything obtains addresses as they should, then I connect the WRT1900ACS and it's the same shit again. To me it seems like a sort of mix between DD-WRT and Windows, perhaps DD-WRT handles DHCP in some sort of unorthodox manner that Windows really doesn't like, but I don't really see how or why that would be
169.254.0.0/16 is APIPA which means an address couldn't be obtained. Any reason why your router's IP is 192.168.5.99? Do you already have a 192.168.1.1 on the same network? It makes sense to me to have the gateway end in .1 at least. Also, a max of 16 DHCP users might be on the low side, though it shouldn't cause any issues. You can also enable syslogd on DD-WRT. As for the client side, I'm sure you already know how to view logs for DHCP on Linux, but here's how to do it on Windows: https://serverfault.com/questions/228342/how-to-enable-debug-of-dhcp-client-on-windows-7
Nah, I've moved it off the default network mostly for fun but also to make it a tiny little bit more secure, .99 to make it easy to remember, 16 users is also just me fucking around with the settings, of course I've also tried using the default settings, but to no avail. Here's the log file (it's identical for both of my Windows systems): https://www.dropbox.com/s/pcb1rigel0zvtk5/VA.evtx?dl=0 I'm not really sure what to make of it apart from something fucking up for some reason
I don't see how 99 is any more memorable or secure, but if setting it back to 1 doesn't fix the issue, then whatever. Have you tried netsh winsock reset catalog netsh int ip reset resetlog.txt ipconfig /release ipconfig /renew Have you tried turning everything off and on again? Have you tried a packet capture using Wireshark?
Sorry, you need to Log In to post a reply to this thread.