• Steam running on WINE 1.0.1; Not launching games
    11 replies, posted
-was running an ancient debian version at the time-
Wine 1.0.1? Um... that version of Wine is at least four years old now, have you tried upgrading it? Newer versions of Wine have much better compatibility with Steam and Source games.
Indeed, you should always be using the latest version when it comes to WINE.
ugh. WINE is very fiddly. Check out PlayOnLinux. [url]http://www.playonlinux.com/en/[/url]
... PlayOnLinux uses WINE.
[QUOTE=nikomo;34808516]... PlayOnLinux uses WINE.[/QUOTE] yes but it's all automated with scripts, any dependencies are automatically configured and it downloads a specific version of WINE that has been tested with the game. It's easier than mucking about with regressions and out dated instructions. your advice on using the latest stable is not always the right path with something like WINE, fixing one thing can break another.
Guess I'll update is as soon as I can. This is a school laptop and we don't have superuser permissions. The update could take quite the time to perform. Also, I noticed that not even GCF standalones seem to work. Older versions of Garry's Mod seem to work just fine. Not sure about things like TF2 or Portal.
You could try to boot in runlevel 1, if you're not prompted for a password you're in luck...
sudo apt-get install wine1.4 password: ******** Success.
I have tried the package install for most of the debian versions as well as ubuntu. What I have found is the package managers like apt-get/aptitude install older versions of Wine. In my experience the best way to get Wine running and working properly is to download it and compile it from source.
Doesn't the wine website offer a bunch of debs for the latest versions.
the official ppa from winehq installs the latest, which is 1.4 at the moment.
Sorry, you need to Log In to post a reply to this thread.