• Vertece Oddities
    9 replies, posted
As you all know, We need to merge vertices on some brushes. namely, arches or so. So I did that to get a 90 degree curve. Also I messed with vertices on slopes, BUT when I reloaded the map in hammer, the vertices are screwed up, and when I try to select one, I select three for some weird reason. Here is a picture [IMG]http://i.imgur.com/ycGtX.png[/IMG] "STRANGE, ISN'T IT?" The odd part is, The map compiles perfectly. Vvis, Vrad, Vbsp, don't choke on it. I don't really know if this is an issue. It is however, untidy. and makes it a pain to deal with in the editor. I hope there is a solution. It ONLY DOES this when I do it, then restart Hammer. LOL It's happened to me frequently
The brush is probably invalid, so hammer tries to correct it.
[QUOTE=Stiffy360;35287204]As you all know, We need to merge vertices on some brushes. namely, arches or so. So I did that to get a 90 degree curve. Also I messed with vertices on slopes, BUT when I reloaded the map in hammer, the vertices are screwed up, and when I try to select one, I select three for some weird reason. Here is a picture [IMG]http://i.imgur.com/ycGtX.png[/IMG] "STRANGE, ISN'T IT?" The odd part is, The map compiles perfectly. Vvis, Vrad, Vbsp, don't choke on it. I don't really know if this is an issue. It is however, untidy. and makes it a pain to deal with in the editor. I hope there is a solution. It ONLY DOES this when I do it, then restart Hammer. LOL It's happened to me frequently[/QUOTE] I'd say just remake the brush, it'll probably fix it.
Remake by hand. Using fancy gizmos will only bring you sorrow.
[QUOTE=ashton93;35287832]I'd say just remake the brush, it'll probably fix it.[/QUOTE] I merged the vertices perfectly, Got no problems, saved, loaded back up, broken. :3 EDIT: OH CRAP. I misspelled the title XD
[QUOTE=Stiffy360;35288040]I merged the vertices perfectly, Got no problems, saved, loaded back up, broken. :3[/QUOTE] Use alt+p whenever you try anything fancy. IF your experience is anything like mine you'll find what you did wasn't so fancy.
[QUOTE=mdeceiver79;35288094]Use alt+p whenever you try anything fancy. IF your experience is anything like mine you'll find what you did wasn't so fancy.[/QUOTE] I did that :3 when I said Got no problems.
[QUOTE=Stiffy360;35288101]I did that :3 when I said Got no problems.[/QUOTE] Hmm interesting. Then Id say rebuild. Use brushes with triangle tops (cut a normal brush in half diagonally) Move them into position so they align in the top view then vertex modify them. Only move vertices up or down. That should alleviate the issues.
I'm sure it compiles fine but those visleafs :tinfoil:
[QUOTE=GameDev;35288303]I'm sure it compiles fine but those visleafs :tinfoil:[/QUOTE] Visleafs are just fine too :V
Sorry, you need to Log In to post a reply to this thread.