• Mapping Question Megathread v3
    4,500 replies, posted
  • [QUOTE=Azzator;35617806]I keep getting this message on the console in-game [code] SERVER: VPhysics Collision detection getting expensive, check for too many convex pieces! [/code][/QUOTE] Custom models with tons of convex collision parts?
  • No custom models at all. Just a lot of rubble props, but I disabled collision on them and I'm still getting it.
  • [QUOTE=Azzator;35617892]No custom models at all. Just a lot of rubble props, but I disabled collision on them and I'm still getting it.[/QUOTE] Well just ignore it then, it won't affect anything.
  • [QUOTE=ThalZaramee;35581625]So it means that i have to set the point_template to spawn items with name, an math counter to count the placed items, and a filter to make it works only with the named items? Okay, but how did i make the items dissapears after that? How it spawn the AR2? And thanks for responding.[/QUOTE] So how i do it?
  • If I released a map named ctf_blah.bsp and then wanted to release an updated map, is it an absolute requirement that the filename be changed to something like... ctf_blah[B]_v2[/B].bsp? Or, can I keep the filename the same (ctf_blah.bsp) and will Source dedicated servers automatically force clients to download the updated version regardless of filename (if a different version of the map is detected through checksums etc??) Honestly I don't have a clue how Source servers work in this area, and my Google-fu is failing me, please enlighten me. Thanks. [edit] Okay I just got PM'd the answer. The server disconnects you if your version of the map is different, but doesn't force your client to auto-download the updated version. So you still have to rename the map either way.
  • [QUOTE=ThalZaramee;35618811]So how i do it?[/QUOTE] func_remove will remove the items, and an AR2 is spawned from a point_template. Knowing the basics of hammer, and the way to spawn objects in the first place, you couldn't work that out?
  • [QUOTE=Miigga;35607812][t]http://i.imgur.com/DU60X.jpg[/t] source what the fuck are you doing The map isn't even leaking but these walls are just not complying. Stupid looking lighting all over them. No errors in the compile log as far as I can tell and lighting is fine everywhere else in the map. Also can't be caused by prop shadows because the problem persists even if I turn off the props and compile how fix[/QUOTE] The issue might be linked to the size of lightmaps.
  • [QUOTE=Legend286;35618094]Well just ignore it then, it won't affect anything.[/QUOTE] My map crashes into 5 minutes of playing it.
  • Is there a way to prevent the 3D-skybox from being cut off when looking at it from a low angle? [t]http://i.imgur.com/dGdTn.jpg[/t]
  • [QUOTE=Azurblau;35620036]Is there a way to prevent the 3D-skybox from being cut off when looking at it from a low angle? [t]http://i.imgur.com/dGdTn.jpg[/t][/QUOTE] Can't in HL2, it's probably doable in gmod with custom view render shit, but if you lower the nearz in a mod then yes.
  • Is it possible to add like a water dripping effect in Hammer? I have a room full of pipes and I'd like to have like water dripping from one of them.
  • [QUOTE=H4wkeye;35620356]Is it possible to add like a water dripping effect in Hammer? I have a room full of pipes and I'd like to have like water dripping from one of them.[/QUOTE] Episode 2 has some nice particles for that.
  • [QUOTE=H4wkeye;35621001]Can I use that in L4D2 authoring tools? Since it's a L4D2 map.[/QUOTE] I'm sure L4D2 has some too, look in the particle editor or on the VDC particle list.
  • Will do. Thanks! [editline]18th April 2012[/editline] Well, all the .pcf files are inside the main .vpk files, so I had to use GFCScape to extract the particle folder form there to the one that already exists inside l4d folder in order to be able to view the particles. But, it was worth it, L4D2 has some really neat particles effects, especially for rain/water since I needed that.
  • Sorry to repost but nobody has answered my question for two days: For some reason the shadows cast by my trees don't effect npcs, anybody know how to fix this? [IMG]http://img809.imageshack.us/img809/844/sdkcustommodeltest0000.jpg[/IMG]
  • Weird issue, gotta say. Unfortunately I don't know what could cause or how to solve it :(
  • [QUOTE=H4wkeye;35623086]Weird issue, gotta say. Unfortunately I don't know what could cause or how to solve it :([/QUOTE] Are you serious? I don't mean to sound like a dick, but post was [I]completely[/I] useless. And yes, I am aware of the hypocrisy.
  • The guy said he did not get a reply in 2 days. Now he did. I at least said something, so that he doesn't think no one even cared or looked at his post. And besides, I don't see why are you so concerned about my post.
  • [QUOTE=bIgFaTwOrM12;35622773]Sorry to repost but nobody has answered my question for two days: For some reason the shadows cast by my trees don't effect npcs, anybody know how to fix this? [IMG]http://img809.imageshack.us/img809/844/sdkcustommodeltest0000.jpg[/IMG][/QUOTE] This is probably not the best solution, but I think it might work to put some brushes with the blocklight texture around the height of the leaves, might cause some odd looking shadows if the brushes are to big, though.
  • [QUOTE=bIgFaTwOrM12;35622773]Sorry to repost but nobody has answered my question for two days: For some reason the shadows cast by my trees don't effect npcs, anybody know how to fix this? [IMG]http://img809.imageshack.us/img809/844/sdkcustommodeltest0000.jpg[/IMG][/QUOTE] Try to change the sun falling angle to see how it turns out
  • [QUOTE=bIgFaTwOrM12;35622773]Sorry to repost but nobody has answered my question for two days: For some reason the shadows cast by my trees don't effect npcs, anybody know how to fix this? [IMG]http://img809.imageshack.us/img809/844/sdkcustommodeltest0000.jpg[/IMG][/QUOTE] I'm not sure I know what I'm talking about, but do you have a shadow_control entity? maybe that helps..? at least it will make the npcs have their own shadows..
  • [QUOTE=GoldPlatinum;35624244]Try to change the sun falling angle to see how it turns out[/QUOTE] I've tested it at various sun angles, no matter what the trees' shadows don't effect npcs. [QUOTE=Kacukamari;35624244]I'm not sure I know what I'm talking about, but do you have a shadow_control entity? maybe that helps..? at least it will make the npcs have their own shadows.[/QUOTE] Yeah, I think it'll just give the npcs shadows on the ground, it won't effect their actual lighting. Edit: If it's any help, I'm using Staticproplighting, Staticproppolys and Textureshadows in expert compile so that the lighting of static props is based off of the actual model rather than just the collision model.
  • Can someone tell me why do my windows look like this when shattered? :v: [t]http://d.localhostr.com/file/JtcsrUY/Untitled.png[/t]
  • [QUOTE=H4wkeye;35627759]Can someone tell me why do my windows look like this when shattered? :v: [t]http://d.localhostr.com/file/JtcsrUY/Untitled.png[/t][/QUOTE] Probably happens for a couple of reasons. 1. You have a leak or something 2. may be a cubemap issue? try adding one. 3. glass's origin is getting weird light.
  • There is no leaks. There is env_cubemap in front of each glass and I've built cubemaps. The only one I could think of is your 3rd point: weird light. I'll add some more light and test it out.
  • [QUOTE=H4wkeye;35627759]Can someone tell me why do my windows look like this when shattered? :v: [t]http://d.localhostr.com/file/JtcsrUY/Untitled.png[/t][/QUOTE] I believe that's normal for a window to look like that after being shot if it's a func_breakable_surf. You could try changing them to normal func_breakables and giving them the "glass" material type to see which one you would prefer.
  • [QUOTE=mcilona;35630274]I believe that's normal for a window to look like that after being shot if it's a func_breakable_surf. You could try changing them to normal func_breakables and giving them the "glass" material type to see which one you would prefer.[/QUOTE] Yes, this seems to be the case, I've just found out. The glassbreakable70a texture is like that when it shatters it seems. The other one I tried wasn't. Also, a quick question. Not sure if I'm doing something wrong but some particles, while I can see them in the browser don't appear in game and also, aligning them is quite hard, since in the editor you don't see the particle itself so it's hard to put it properly, is there any way I don't know of about how to "aim" the particles in the editor properly?