• Mapping Question Megathread v3
    4,500 replies, posted
  • Avatar of GoldPlatinum
  • [QUOTE=Doom;35771282]So I've been wondering. How exactly do you take screenshots like this (IE. without any hud nor weapon appearing on your screen) [IMG]http://desmond.imageshack.us/Himg713/scaled.php?server=713&filename=atlantisremakeplus0000.jpg&res=landing[/IMG][/QUOTE] cl_drawhud 0 in console.
  • Avatar of Doom
  • [QUOTE=GoldPlatinum;35771446]cl_drawhud 0 in console.[/QUOTE] That removes the hud, not the weapon.
  • Avatar of Legend286
  • [QUOTE=Doom;35771568]That removes the hud, not the weapon.[/QUOTE] r_drawviewmodel 0. GlodPlatnum is a dumbass!!!
  • Avatar of Doom
  • [QUOTE=Legend286;35771639]r_drawviewmodel 0. GlodPlatnum is a dumbass!!![/QUOTE] Thank you :)
  • Avatar of vexx21322
  • My shadows keep riding up on the wall. [t]http://puu.sh/skJX[/t] My light_environment settings are: 0 108 0 -35
  • Avatar of DireAvenger
  • Holy shit So I decided to get back into mapping after so fucking long and it turns out I've lost my ability to seal leaks. [url]http://filesmelt.com/dl/dickslord.zip[/url] Could someone tell me why that brush is stopping me from compiling? I recall that func_brush sealed leaks. Maybe I'm being retarded.
  • Avatar of slayer20
  • [QUOTE=DireAvenger;35780273]Holy shit So I decided to get back into mapping after so fucking long and it turns out I've lost my ability to seal leaks. [url]http://filesmelt.com/dl/dickslord.zip[/url] Could someone tell me why that brush is stopping me from compiling? [B]I recall that func_brush sealed leaks.[/B] Maybe I'm being retarded.[/QUOTE] Entities can't be touching the void.
  • Avatar of DireAvenger
  • [QUOTE=slayer20;35780527]Entities can't be touching the void.[/QUOTE] ffffffffff I'll un-brushify the things sealing it off That fixed it, thanks for the help.
  • Avatar of iostream
  • Why is Tools -> Align/Flip Objects sometimes enabled, and sometimes not? I'm yet to find any patterns to this. For example when align/flip get disabled, I can shift-drag some object and go to the Tools menu, and find that they are again enabled, and the keyboard shortcuts works again (but not before going to the actual menu). Really weird.
  • Avatar of iostream
  • [QUOTE=H4wkeye;35783166]What does interpolate time do in env_fog_controller?[/QUOTE] Seems to be the duration of its "StartFogTransition" event or something.
  • Avatar of H4wkeye
  • I'm having trouble with playing my custom sound in game. In Hammer it plays just fine but when I go in game, and trigger it, I get an error in the console saying "S_StartSound: Failed to load sound file probably missing from disk/repository". The sound file is a .wav, 44.1khz and it's looped using waveousaur. It's in sound/custom/music (since I read that putting it directly in sound dir can cause bugs). Still, it doesn't want to play in game. Any ideas? [editline]1st May 2012[/editline] I forgot to rebuild the sound cache. Silly me. Problem solved. :smith:
  • Avatar of Prez
  • So I've been mapping in CS:S for a very long time, just because a community I was in was CS:S only. Should I switch back to mapping in HL2? And would it be with HL2:DM (if it is, looks like I can only use the 2006 source engine. is that okay?). Thanks!
  • Avatar of Firegod522
  • CS:S and Hl2:DM are both on source engine MP. CS:S has all the content that hl2:dm and hl2 has, plus its own, so CS:S would be a better choice in texture and model content.
  • Avatar of mattmanlex
  • I'm trying to put in a stairs model in a portal 2 map, and I used prop_static. But, when I test it in-game, it doesn't show up! In Editor: [img]http://puu.sh/subE[/img] In-Game: [img]http://puu.sh/suaw[/img] Any help? Oh, and another question. How do you make the moveable panels? I'm thinking about replacing the catwalk stairs with one of those.
  • Avatar of H4wkeye
  • Make sure the prop is not into any of the brushes, even a tiny bit or else it won't spawn. At least, mine never do when they are touching the brush a bit (prop_statics at least).
  • Avatar of mattmanlex
  • [QUOTE=H4wkeye;35789765]Make sure the prop is not into any of the brushes, even a tiny bit or else it won't spawn. At least, mine never do when they are touching the brush a bit (prop_statics at least).[/QUOTE] Ah, i'll try that. Thanks. Also, how do I make the door open when I get near it?
  • Avatar of H4wkeye
  • With a trigger. Put down a trigger_multiple. Then make your door and name it, like door1. Then on the trigger_multiple under Output add a new one OnStartTouch > door1 > open.
  • Avatar of GoldPlatinum
  • [QUOTE=H4wkeye;35790516]With a trigger. Put down a trigger_multiple. Then make your door and name it, like door1. Then on the trigger_multiple under Output add a new one OnStartTouch > door1 > open.[/QUOTE] Then OnEndTouch > door1 > Close
  • Avatar of mattmanlex
  • [QUOTE=GoldPlatinum;35791536]Then OnEndTouch > door1 > Close[/QUOTE] That seems like it would work, but I can't seem to get the trigger brush to be invisible when testing. Maybe it's glaringly obvious and i'm dumb, but I can't get it to work!
  • Avatar of vexx21322
  • [QUOTE=mattmanlex;35791836]That seems like it would work, but I can't seem to get the trigger brush to be invisible when testing. Maybe it's glaringly obvious and i'm dumb, but I can't get it to work![/QUOTE] The entire thing is textured in the trigger texture?
  • Avatar of mattmanlex
  • [QUOTE=vexx21322;35791930]The entire thing is textured in the trigger texture?[/QUOTE] Completely, yes.
  • Avatar of GoldPlatinum
  • [QUOTE=mattmanlex;35791836]That seems like it would work, but I can't seem to get the trigger brush to be invisible when testing. Maybe it's glaringly obvious and i'm dumb, but I can't get it to work![/QUOTE] Did you convert it into a trigger_multiple entity? Because simply making a block with a trigger texture wont work.
  • Avatar of James
  • Hey. I don't come in this section often , I'm more a Lua coder type of guy, but I have some questions concerning mapping. I need to use smoothing groups, and no matter what I do ( on a pillar for example ), the contrast between the shadows on 2 adjacent faces make my map look really blocky. Could anyone help me and give me a point in the right direction for using this feature? Thanks
  • Avatar of Firegod522
  • [QUOTE=James xX;35793858]Hey. I don't come in this section often , I'm more a Lua coder type of guy, but I have some questions concerning mapping. I need to use smoothing groups, and no matter what I do ( on a pillar for example ), the contrast between the shadows on 2 adjacent faces make my map look really blocky. Could anyone help me and give me a point in the right direction for using this feature? Thanks[/QUOTE] Make sure the lightmap grid is aligned properly. You may have to lower the lightmapscale.
  • [QUOTE=James xX;35793858]Hey. I don't come in this section often , I'm more a Lua coder type of guy, but I have some questions concerning mapping. I need to use smoothing groups, and no matter what I do ( on a pillar for example ), the contrast between the shadows on 2 adjacent faces make my map look really blocky. Could anyone help me and give me a point in the right direction for using this feature? Thanks[/QUOTE] Could also try adding more faces to the object.
  • Avatar of H4wkeye
  • [QUOTE=mattmanlex;35791836]That seems like it would work, but I can't seem to get the trigger brush to be invisible when testing. Maybe it's glaringly obvious and i'm dumb, but I can't get it to work![/QUOTE] When you make the brush and texture it in Trigger texture, select it and press ctrl+t to tie it to an entity, then in the list select trigger_multiple and click apply.
  • Avatar of Rzor
  • Does anyone know how to open these? [IMG]http://puu.sh/sySo[/IMG]