• What are you working on? May 2012
    2,222 replies, posted
  • [QUOTE=WTF Nuke;35896807]Why's it on the side?[/QUOTE] Code visibility. That's the second one by the way, dedicated to IDEs and console prompts.
  • Aight I'm working on a really simple horror game in XNA and am curious how I would add a simple flash light to my game. By simple I mean like cut and dry flash light no shadows or anything. More a less like a mask. I will gladly post up my game after I get this part done. Besides that it's pretty much done.
  • Ok guys. I'm making another XNA game here. This time an isometric viewpoint game. I really don't have a clue about techniques and I'm probably doing a lot of things wrong.. However: Each Tile is its own tile in its own class. There is grid class that holds a 2d array of the Tile class. Each Tile is a sprite that looks like this:[img]http://i.imgur.com/cpncz.png[/img] When displaying the grid I just moved them around to fit nicely. When using rectangles, how can I put them at an angle without disturbing the sprite that is attached to the rectangle? [t]http://i.imgur.com/QyCZt.png[/t]
  • [QUOTE=Zombiedance;35897057]Aight I'm working on a really simple horror game and am curious how I would add a simple flash light to my game. By simple I mean like cut and dry flash light no shadows or anything. More a less like a mask. I will gladly post up my game after I get this part done. Besides that it's pretty much done.[/QUOTE] Just draw a huge black image with a clear part in the middle for where the 'light' is supposed to be. [QUOTE=Mr_Razzums;35897082]iso stuff[/QUOTE] [URL]http://www.wildbunny.co.uk/blog/2011/03/27/isometric-coordinate-systems-the-modern-way/[/URL]
  • [QUOTE=chimitos;35897100]Just draw a huge black image with a clear part in the middle for where the 'light' is supposed to be.[/QUOTE] I did that but it doesn't look to nice.
  • [QUOTE=chimitos;35897100]Just draw a huge black image with a clear part in the middle for where the 'light' is supposed to be. [URL]http://www.wildbunny.co.uk/blog/2011/03/27/isometric-coordinate-systems-the-modern-way/[/URL][/QUOTE] Seems like it could be of value! Thanks!
  • Textures as promised, the developers at vatra have had some nice photoshop fun: Some placeholders [img]http://i.imgur.com/tccq7.png[/img][img]http://i.imgur.com/crmjH.png[/img] Entity zone tag images [img]http://i.imgur.com/VQgVT.png[/img][img]http://i.imgur.com/SDAhv.png[/img] Beretta with bump map [img]http://i.imgur.com/Fopiz.png[/img][img]http://i.imgur.com/U0l6T.png[/img]
  • [QUOTE=BlkDucky;35894235]GTX560ti, solid 60FPS.[/QUOTE] GTX 560 Ti master race! Honestly though, it's a (very) decently priced card to performance ratio.
  • [QUOTE=COBRAa;35898721]GTX 560 Ti master race! Honestly though, it's a (very) decently priced card to performance ratio.[/QUOTE] 8800GT represent best card ever
  • [QUOTE=swift and shift;35898928]8800GT represent best card ever[/QUOTE] I had the GTX. It was fine until the soldering melted. I'm glad the game seems to be running fine for almost all of you, did you all zoom out as far as you could? And I'll look into getting it working on Linux today.
  • [QUOTE=Ziks;35894034]Could I get some of you to test how well / if my city generator and renderer works on your machines? The city generated is very basic at the moment with only one type of building with no detail. I've only tested on nVidia cards so I expect some horrible bug on ATI cards. You should be getting a solid 60 FPS. [img]http://puu.sh/tRyn[/img] [URL="http://puu.sh/tRxZ"]Download[/URL] readme.txt: [code]Keys: WASD - Move camera QE - Rotate camera X - Toggle interior view M - Toggle map view Mouse Wheel - Zoom[/code] Oh also G to generate a new city.[/QUOTE] This is what I get on my ATI Mobility Radeon HD 3450. [img]http://puu.sh/tVWy.png[/img]
  • [QUOTE=Naelstrom;35894390]Doesn't work at all here. [img_thumb]http://bit.ly/KbyFVq[/img_thumb] Nvidia GTX 260 linux. Also crashes when generating a new city [code]Unhandled Exception: System.Exception: OpenGL hates your guts: InvalidOperation at Zombles.Graphics.VertexBuffer.CheckForError () <0x0007a> at Zombles.Graphics.VertexBuffer.SetData<single> (single[]) <0x00091> at Zombles.Geometry.City.UpdateVertexBuffer () <0x0006e> at Zombles.Geometry.Generation.CityGenerator.Generate (int,int,System.Random) <0x0005f>[/code] I love the error message.[/QUOTE] Apparently your card only supports OpenGL 2.1, and I'm using some 3+ features. Since it works with robmaister's linux partition I'll assume it will work for pretty much everyone on linux who's card supports it.
  • [QUOTE=usa;35898598] Beretta with bump map [/QUOTE] I hope that isn't 1:1 to what you're actually using in-game, unless they're third person.
  • [QUOTE=Perl;35891651][IMG]http://puu.sh/tPGI[/IMG] because fuck all logic if turb sees this.. :v:[/QUOTE] Did you write your own lexer or are you using a library for it? If the latter, which library?
  • [QUOTE=Ziks;35899392]Apparently your card only supports OpenGL 2.1, and I'm using some 3+ features. Since it works with robmaister's linux partition I'll assume it will work for pretty much everyone on linux who's card supports it.[/QUOTE] My card is getting that old? Oh dear :( However, I'm able to compile shaders that contain OpenGL 3.3 features on my card and they work fine. You sure that's the cause?
  • [QUOTE=calzoneman;35900555]Did you write your own lexer or are you using a library for it? If the latter, which library?[/QUOTE] He's written his own.
  • Finished my .net project that keeps track of dead homeless people for the city (g3t payd $$$). Finished all classes. Finished coldfusion(LOL) inspection app. Updated 3 websites. Now I'm at work with no more projects! I want to be home working on sanic game and isometric rpg game!!
  • [QUOTE=Naelstrom;35900595]My card is getting that old? Oh dear :( However, I'm able to compile shaders that contain OpenGL 3.3 features on my card and they work fine. You sure that's the cause?[/QUOTE] I'll add some more debugging output later so we can find out the problem.
  • [QUOTE=Ziks;35899392]Apparently your card only supports OpenGL 2.1, and I'm using some 3+ features. Since it works with robmaister's linux partition I'll assume it will work for pretty much everyone on linux who's card supports it.[/QUOTE] The GTX 260 supports OpenGL 3.3 :|
  • [QUOTE=Chandler;35900945]The GTX 260 supports OpenGL 3.3 :|[/QUOTE] I was just going by [url=http://www.geforce.com/hardware/desktop-gpus/geforce-gtx-260/specifications]this[/url], I didn't check for any other sources.
  • [IMG]http://i.imgur.com/piixD.png[/IMG] Tone mapped and now with a skybox. At the top from left to right, albedo, normals, depth, lightmap, pre-post processing (pixelated since mipmaps are enabled to give me a cheapish way of getting average luminosity). There is some artifacting on the edges of the model :S
  • [QUOTE=Ziks;35894034]Could I get some of you to test how well / if my city generator and renderer works on your machines? The city generated is very basic at the moment with only one type of building with no detail. I've only tested on nVidia cards so I expect some horrible bug on ATI cards. You should be getting a solid 60 FPS. [IMG]http://puu.sh/tRyn[/IMG] [URL="http://puu.sh/tRxZ"]Download[/URL] readme.txt: [code]Keys: WASD - Move camera QE - Rotate camera X - Toggle interior view M - Toggle map view Mouse Wheel - Zoom[/code] Oh also G to generate a new city.[/QUOTE] Steady 60 fps, draws nothing Geforce 6600 256 MB Edit: crashes when I press G
  • So, for ages I've been trying to implement chat emoticons in Steam... [img]http://peniscorp.com/stuff/SS-2012-05-10_17.40.47.png[/img] Close enough :v:
  • [QUOTE=ichiman94;35901514]Steady 60 fps, draws nothing Geforce 6600 256 MB Edit: crashes when I press G[/QUOTE] 6600 only supports opengl 2.1
  • [QUOTE=Ziks;35894034]Could I get some of you to test how well / if my city generator and renderer works on your machines? The city generated is very basic at the moment with only one type of building with no detail. I've only tested on nVidia cards so I expect some horrible bug on ATI cards. You should be getting a solid 60 FPS. [IMG]http://puu.sh/tRyn[/IMG] [URL="http://puu.sh/tRxZ"]Download[/URL] readme.txt: [code]Keys: WASD - Move camera QE - Rotate camera X - Toggle interior view M - Toggle map view Mouse Wheel - Zoom[/code] Oh also G to generate a new city.[/QUOTE] Solid 60FPS, GTX 560 Ti 1GB.
  • [QUOTE=Ziks;35894034]Could I get some of you to test how well / if my city generator and renderer works on your machines? The city generated is very basic at the moment with only one type of building with no detail. I've only tested on nVidia cards so I expect some horrible bug on ATI cards. You should be getting a solid 60 FPS. [IMG]http://puu.sh/tRyn[/IMG] [URL="http://puu.sh/tRxZ"]Download[/URL] readme.txt: [code]Keys: WASD - Move camera QE - Rotate camera X - Toggle interior view M - Toggle map view Mouse Wheel - Zoom[/code] Oh also G to generate a new city.[/QUOTE] Stable 59.97 FPS, GT 530, city generating takes less that half-a-second.
  • I've started working on the UI of our game. Not a single line of code written yet, but made a fancy chart. :v: [IMG]http://i.snag.gy/isktr.jpg[/IMG]
  • So there's been quite a bit of a commotion in the FPP group the past few days. I could explain it all but I made a video instead. [media]http://www.youtube.com/watch?v=RWopWAGsGq4[/media]
  • 1996002 triangles, runs at ~40ms/frame. Damn blurry texture, need to enable storing of custom resolution textures [IMG]http://dl.dropbox.com/u/33076954/New/2million.PNG[/IMG] Lighting calculated from a lightsource rather than being ambient. Currently largely CPU bound due to sorting triangles to be tessellated, and getting rid of triangles not meant to be drawn. Tempted to disable tessellation entirely, although I could just sort it in multiple threads at once