• Linux: Mouse is hidden, mouse rotation bound by screen borders
    14 replies, posted
I've tried to find an existing thread to no avail, hopefully someone here can shed a light on this. I'm running Rust on Linux, and I'm currently experiencing two possibly related bugs. The first bug is that when I launch the game, my mouse cursor hides itself. It does this until I switch to a TTY and back to X. At this point, the mouse cursor displays correctly, but it keeps displaying even when I join a game. This leads me into the second bug. The second bug I'm experiencing is that when I move my mouse in-game, I can't rotate infinitely. When my cursor reaches the edge of my screen, I can't rotate any more. So if I'm turning right a lot, eventually (after approximately one whole spin) I'll be unable to rotate anymore until I rotate left a bit. This makes it extremely hard to aim properly in game. Here's a bit of detail on my setup: OS: GNOME Ubuntu 13.10 WM: GNOME 3.10 Screen resolution: 1920x1200
+1 for this same problem but on a dual mionitor setup and the cursor leaves the window when I play. Also no way to go fullscreen. Can't play the game like this, the mouse cursor needs to lock to the center of the window.
Mouse cursor isnt hidden for me, but same problem in that mouse doesn't remain centered and stops controlling the camera when outside the window frame. Cant find a way to force fullscreen either. Trying to find launch flags or setup.cfg options but no luck yet. Edit: Does anyone know the launcher flag to force fullscreen? [editline]15th December 2013[/editline] Fixed the cursor issue by opening config.cfg And then changing [code] cursor.lock True cursor.recenter True cursor.uncenter False [/code] Still no joy on changing fullscreen and resolution options.
[QUOTE=Abyssus;43187575]Mouse cursor isnt hidden for me, but same problem in that mouse doesn't remain centered and stops controlling the camera when outside the window frame. Cant find a way to force fullscreen either. Trying to find launch flags or setup.cfg options but no luck yet. Edit: Does anyone know the launcher flag to force fullscreen? [editline]15th December 2013[/editline] Fixed the cursor issue by opening config.cfg And then changing [code] cursor.lock True cursor.recenter True cursor.uncenter False [/code] Still no joy on changing fullscreen and resolution options.[/QUOTE] It seems that I was able to fix the issue by setting the cfg settings to the ones that you posted, but now when I enter a game, the game will work fine until I try to rotate. It will rotate for about a 10th of a second, and then Rust will completely freeze. Actually it seems all of GNOME will freeze until I switch to a TTY and manually SIGKILL the rust process.
No Gnome freezing but yeah same thing as Gexcolo, maybe that is why it floats by default. This must still be being worked on. Wish I could submit a bug >
for fullscreen: ~/.config/unity3d/Facepunch Studios/PlayRust/prefs <pref name="Screenmanager Is Fullscreen mode" type="int">1</pref> btw i do have similar issues with the mouse but for me it just constantly moves the mouse up until the game freezes..then i alt+tab or switch workspace to bring it back and it starts moving up again until it freezes (no gamepads/controllers attached) MATE desktop with marco window manager. but the game works perfectly with no issues on xfwm4 (XFCE window manager) so it seems unity3d games have issues with some window manager.. Rust is not the first one. [B]edit:[/B] i asked Verdun Guys what they did to fix their mouse bug issue with their latest update... the answer was: VerdunGame [developer] 12 Dec @ 6:16pm "mouse issue solved due to unity engine update." [url]http://steamcommunity.com/app/242860/discussions/0/648813728557855379/#p3[/url] so i guess its fixed in Unity 4.3? [B]edit2:[/B] Linux: Fix custom cursor handling when hiding/showing cursor. [url]http://unity3d.com/unity/whats-new/unity-4.3[/url]
I experience intermittent game freezing (fixed by pressing the unity key or ALT+TAB) but it's not that bad. Managed to get a 3hr game session in today. Looking forward to a more solid fix though.
For anyone having problems still these three things worked perfectly for me: 1. Edit ~/.local/share/Steam/SteamApps/common/rust/cfg/config Set : (might also want to disable grass while you are in here) [CODE]cursor.lock True cursor.recenter False cursor.uncenter False [/CODE] 2. Edit ~/.config/unity3d/Facepunch\ Studios/PlayRust/prefs Set: [CODE]<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>[/CODE] 3. Set your steam launch option to: [CODE]-popupwindow[/CODE] No form of windowed mode worked for me, though I am able to alt-tab out and use my second monitor so it works pretty good. Now if I could just stop getting raided!
@thelamer123 sadly doesnt fix for me i can only play when using XFCE's window manager (xfwm4 --replace) with MATE (marco) window manager it goes out of control sadly :(
thelamer123, I am unfortunately still experiencing the same issue with your fix. And per the advice of Xpander, I tried running rust under Xfce, but still experienced the same issue.
im having the cursor constantly even in xfce. and cursor.lock true just lock everything up when in fullscreen. and garry said in another thread that they do intend to make a build from updated unity. so don't worry
[QUOTE=Xpander;43188810] btw i do have similar issues with the mouse but for me it just constantly moves the mouse up until the game freezes..then i alt+tab or switch workspace to bring it back and it starts moving up again until it freezes (no gamepads/controllers attached) MATE desktop with marco window manager. but the game works perfectly with no issues on xfwm4 (XFCE window manager) [/QUOTE] have the exact same problem as you also using mate. Thanks for the heads up on xfce, I don't really want to install another WM though.. but will if it isn't fixed soon
[QUOTE=Scaramanga;43351133]have the exact same problem as you also using mate. Thanks for the heads up on xfce, I don't really want to install another WM though.. but will if it isn't fixed soon[/QUOTE] the strange thing is that i have couple of friends who also use MATE and they dont have mouse issues... and i have heard some have issues under xfce with mouse.. so its super weird issue.. totaly random.. Maybe some sort of hardware causes that? no idea and it does happen with other unity3d games as well.
[QUOTE=thelamer123;43199149]For anyone having problems still these three things worked perfectly for me: 1. Edit ~/.local/share/Steam/SteamApps/common/rust/cfg/config Set : (might also want to disable grass while you are in here) [CODE]cursor.lock True cursor.recenter False cursor.uncenter False [/CODE] 2. Edit ~/.config/unity3d/Facepunch\ Studios/PlayRust/prefs Set: [CODE]<pref name="Screenmanager Is Fullscreen mode" type="int">1</pref>[/CODE] 3. Set your steam launch option to: [CODE]-popupwindow[/CODE] No form of windowed mode worked for me, though I am able to alt-tab out and use my second monitor so it works pretty good. Now if I could just stop getting raided![/QUOTE] Thanks! This removed my cursor and gave me correct control for a FP game. I didn't have a cfg file originally. What you have to do (if you don't have the cfg file mentioned) is go into the game and rebind one key away from default. Then exit the game and you will find that you have the cfg file. From there make your cursor changes and you should be good to go. Remap the key back to default if you prefer, the cfg file will remain
That worked perfectly for the mouse problem, but my game still freezes after ~1min. ALT+TAB, CTRL+ALT+F1 doesn't work, everythings frozen :( I'm running Ubuntu 13.10, newest version of AMD Catalyst driver 13.12 /EDIT: I didn't change anything, but this time i could play for 30min no freeze/crash, but then a zombie killed me :D Something else i noticed, everytime i close the inventory the mouse moves itself slightly down+right.
Sorry, you need to Log In to post a reply to this thread.