• Rust startup crash (new player, help greatly appreciated)
    4 replies, posted
Finally, Rust is in sale and ready to mingle. I downloaded the game through steam (23 november) After pressing play there showed an small image, a rust logo visible in the bottom and a loading bar in the middle. After a few seconds the loading bar completed the image disappeared. Around 10 seconds later I got a crash message: ''Rust has encountered an error and must close.'' Followed by the name of the crashreport(at the bottom of post) and asking me if I would like to open it. So I can't launch the game. My passion for the game drove me to search for a fix, I've yet to be succesfull. Here are the things that I have tried: note I rebooted my PC after each step. 1.verify integrity 2. reinstall 3.Try admin privilages 4.reinstall easyanticheat 5.Install everything in _CommonRedist 6. Tried Rustclient.exe, this started a black window where after a few seconds music started playing.(waited it out roughly 10 mins, nothing happened) 7. Checked graphics drives, yep there uptodate 8. reinstalled OS (win 10 home pro, 64bit) 9. tried the unplug jacks fix, suggested online 10. checked firewall, should not be a problem. And here I am now, surrendering to trying to find the fix on my own and asking for help. If anyone has a suggestion please post it and I will definitely try it out. Thank you so much for your help. -Esperon Here is the crashreport I get after starting the game: Rust [version: Unity 2017.1.2f1 (cc85bf6a8a04)] RustClient.exe caused an Access Violation (0xc0000005)   in module RustClient.exe at 0033:6465ef9f. Error occurred at 2017-11-24_144250. C:\Program Files (x86)\Steam\steamapps\common\Rust\RustClient.exe, run by (sensored ). 30% memory in use. 8134 MB physical memory [5690 MB free]. 16326 MB paging file [13911 MB free]. 134217728 MB user address space [134217094 MB free]. Read from location 00000020 caused an access violation. Context: RDI:    0xffffffff  RSI: 0x00000000  RAX:   0x00000000 RBX:    0x07323d70  RCX: 0x00000000  RDX:   0xffffffff RIP:    0x6465ef9f  RBP: 0x005feae0  SegCs: 0x00000033 EFlags: 0x00010246  RSP: 0x005fe9d8  SegSs: 0x0000002b R8:    0x00000000  R9: 0x005fec30  R10:   0x42380024 R11:    0x005feb20  R12: 0x00000000  R13:   0x00000001 R14:    0x00000000  R15: 0x00000110 Bytes at CS:EIP: 41 8b 48 20 41 8b 40 18 8d 04 48 41 8b 48 24 99  (Stack has been removed due to post length limit ) Thanks again for helping me.
Try to change your steam download directory to something else and re-install the game. steam settings -> downloads -> STEAM LIBRARY FOLDERS (at top)
Thank you so much for your suggestion Unfortunately it did not fix the problem, I installed it on my other drive but still faced the error screen.
Try putting this in your launch parameters, This seemed to help someone with a similar issue. -force-d3d11 -force-gfx-direct -force-d3d11-no-singlethreaded -force-feature-level-11-0 Source: Here
Unfortunately putting it in my lauch options did not fix the issue. But I want to thank you for your help
Sorry, you need to Log In to post a reply to this thread.