• Source Filmmaker FAQ & tech support
    1,986 replies, posted
  • Avatar of GameDev
  • [img]https://dl.dropbox.com/u/6476192/faqbanner.jpg[/img] [code]9:38 PM - Icemaz: make an faq thread in the SFM forum 9:39 PM - Icemaz: or do you want someone else to do it!! 9:40 PM - GameDev: Uhh people will yell at me but w/e 9:40 PM - Icemaz: why will they yell wtf 9:40 PM - GameDev: i make all the threads lmao 9:40 PM - Icemaz: people have explicitly asked for an faq thread 9:40 PM - GameDev: w/e ill do it!!!! 9:40 PM - GameDev: !! [/code] [U]Solved Questions:[/U] [quote][U][B]"How do I get rid of these bright specks?"[/B][/U] [thumb]http://puu.sh/Fbz1[/thumb] Go to console in game or in SFM and type 'mat_specular 0'[/quote] [quote][U][B]"My shadows are all grainy and look weird, how do I fix this?"[/B][/U] You can fix this by either forcing DoF in Render settings to 32 or above, or messing around with SSAORadius in the animation set of your camera.[/quote] [quote][U][B]"Help! My videos are darker than usual when I export them!"[/B][/U] Use another codec than MPEG-4.[/quote] [quote][U][B]"ZOMGWTF?? My player is just a black silhouette when I'm in game![/B][/U] Doesn't matter, it will show up fine in SFM after you record.[/quote] [quote][U][B]How do I kill my puppets?[/B][/U] You cannot shoot your puppets, you must use 'kill' or 'explode' when recording, then shoot when they die. You can, however, kill people in a multiplayer server. [/quote] [quote][U][B]Just how in the hell do I get DoF to work?[/B][/U] In order for DoF to work, you must create an animation set for your camera and adjust the settings in the motion editor. Note that you can only see these changes previewed when in the clip editor and select mode while you are paused.[/quote] [quote][U][B]"How do I lock a hat or an object onto a player?"[/B][/U] This one is hard to get used to. In the animation set editor, click and drag the body part you wish to lock the model to onto it's check box (I.E. Drag 'Bip_LHand' onto 'w_pistol'). Then go to the motion editor and use the playhead preset to iron out the countermotion it creates from being locked. Save changes and review your work. If you're still confused, review Bay Raitt's SFM Locks tutorial, just imagine the camera is a hat or a model. [video=youtube;dH0A8U2c3UY]http://www.youtube.com/watch?v=dH0A8U2c3UY[/video] [editline]1[/editline] Thanks to Jojje for this great hat tutorial. [video=youtube;Dx5EJlcFjBA]http://www.youtube.com/watch?v=Dx5EJlcFjBA[/video][/quote] [quote][U][B]Does SFM have multiplayer?[/B][/U] Yes, but LAN only. Bypass this via hamachi.[/quote] [quote][B][U]"How do I make my medic heal recordings without multiplayer?[/U][/B] [video=youtube;jC_cMQJ1xvc]http://www.youtube.com/watch?v=jC_cMQJ1xvc[/video][/quote] [quote][B][U]"I Get a nice white line through my viewport like this, what's causing it?[/U][/B] [video=youtube;29tMKAyq6Dg]http://www.youtube.com/watch?v=29tMKAyq6Dg&feature=player_embedded[/video] You probably are using an integrated chipset and don't meet the minimum specs. Refer to the "What are the specs for SFM?" Question. [editline]1[/editline] Critnuke found a fix for this: [quote]You need to make the camera an animation set, then set the bloom slider all the way to the left. You need to do it for every new camera, but it removes the white line.[/quote] [/quote] [quote][U][B]How do I use my own custom sounds in SFM?[/B][/U] Use a program like Audacity or Audition to encode the file as a 44100 Hz, 16 bit Wave file. Place it in steamapps/common/SourceFilmmaker/game/usermod/sound/[/quote] [quote][B][U]Particles?[/U][/B] Particles. [video=youtube;BMmgyiGF3vU]http://www.youtube.com/watch?v=BMmgyiGF3vU[/video][/quote] [quote][B][U]I have discrete NVIDIA graphics, but my computer keeps using the intel integrated. How do I fix this?[/U][/B] Update your drivers to the latest release, and make sure that sfm.exe is set to prefer the NVIDIA graphics in the NVIDIA control panel.[/quote] [quote][U][B]"What are the minimum specs for SFM?"[/B][/U] Taken from Valve: OS: Windows 7 / Vista (Windows 7 64 bit suggested) Processor: 3.0 GHz P4, Dual Core 2.0 (or higher) or AMD64X2 (or higher) Memory: 2GB (4 GB suggested) Hard Disk Space: At least 15 GB of Space Video: NVIDIA GeForce 200 series card or better, or AMD Radeon 3000 series or better (NVIDIA GeForce 400 series or AMD Radeon 5000 series preferred) Monitor: 1366 x 768 (1920 x 1080 suggested) Audio: DirectX 9.0c compatible USB headset with mic (suggested) [/quote] [B]I'll be adding more questions as this thread progresses.[/B][B][U][/U][/B]
  • Avatar of fruxodaily
  • [QUOTE][B][U]I can't render in 1080p without it crashing/2fort makes the water look like little cubes mixed together[/U][/B] This is a current bug with Source Filmmaker and we're expecting a patch in time[/QUOTE]
  • Avatar of belink
  • Here's a bit of useful info courtesy of p0rtalplayer to get Colour Correction, DoF and other effects to be processed when making posters: [QUOTE=p0rtalplayer;36555657]Easy way around it is to render as a movie, but set the type to "Image sequence" and have it only render one frame, that one being whatever frame of the movie you want.[/QUOTE]
  • Avatar of inzuki
  • There should be a better fix for the player being a big black blob of squares. It'd get pretty annoying having to record yourself when you can't really tell what your player looks like. But besides that, good thread idea. I hope there'll be other things such as tips to making videos look nicer and such.
  • Avatar of JoshuaC
  • [QUOTE=belink;36585330]Here's a bit of useful info courtesy of p0rtalplayer to get Colour Correction, DoF and other effects to be processed when making posters:[/QUOTE] Only issue with this is that you cannot export at 1080p or higher. I just exported the film grain and vignette vtf's and readd them in gimp.
  • Avatar of GameDev
  • [QUOTE=The Inzuki;36585333]There should be a better fix for the player being a big black blob of squares. It'd get pretty annoying having to record yourself when you can't really tell what your player looks like. But besides that, good thread idea. I hope there'll be other things such as tips to making videos look nicer and such.[/QUOTE] It's a bug, I'm sure it will be fixed soon
  • Avatar of Engy
  • [quote]I can't render in 1080p without it crashing/2fort makes the water look like little cubes mixed together This is a current bug with Source Filmmaker and we're expecting a patch in time[/quote] I wonder where this bug even came from? The leak never had an issue rendering at 1080p or whatever custom resolution you chose.
  • Added something to the first Q/A: [QUOTE][B]"How do I get rid of these bright specks?"[/B] [IMG]http://puu.sh/Fbz1[/IMG] Go to console in game or in SFM and type 'mat_specular 0' I recommend putting this command in your autoexec.cfg file. [/QUOTE]
  • Avatar of Tark
  • [QUOTE=Creeper120;36585453]Added something to the first Q/A:[/QUOTE] The autoexec.cfg in which directory? "game/tf/cfg"?
  • [QUOTE=Tark;36585517]The autoexec.cfg in which directory? "game/tf/cfg"?[/QUOTE] "tf/cfg" (create one; if already there, edit it) "tf_movie/cfg" (has to be edited) "usermod/cfg" (has to be edited)
  • Avatar of ElementalCreeds
  • Any fix for this: Inside every camera space is a white line, And really bad fullbrighted graphics. Also when you render it looks like how the camera did, Heres a video: [video=youtube;29tMKAyq6Dg]http://www.youtube.com/watch?v=29tMKAyq6Dg[/video] (not mine)
  • Avatar of GameDev
  • [QUOTE=Unisath;36585617]How exactly can I use locks to merge hats to models?[/QUOTE] Added to OP [editline]1[/editline] [QUOTE=LetsGroove;36585725]What are the specs needed for SFM?[/QUOTE] ditto
  • Avatar of GameDev
  • [QUOTE=ElementalCreeds;36585632]Any fix for this: Inside every camera space is a white line, And really bad fullbrighted graphics. Also when you render it looks like how the camera did, Heres a video: [video=youtube;29tMKAyq6Dg]http://www.youtube.com/watch?v=29tMKAyq6Dg[/video] (not mine)[/QUOTE] I don't think we've actually found a fix yet unless I'm mistaken
  • Avatar of ElementalCreeds
  • [QUOTE=GameDev;36585751]I don't think we've actually found a fix yet unless I'm mistaken[/QUOTE] Odd bug, Hopefully people here will know.
  • Avatar of Unisath
  • Another random question: How do I change the color of a hat? Does it have something to do with the element viewer?
  • Avatar of Bitl
  • [QUOTE=ElementalCreeds;36585632]Any fix for this: Inside every camera space is a white line, And really bad fullbrighted graphics. Also when you render it looks like how the camera did, Heres a video: [video=youtube;29tMKAyq6Dg]http://www.youtube.com/watch?v=29tMKAyq6Dg[/video] (not mine)[/QUOTE] I found a fix for the fullbrighted graphics. Put this in the console: mat_picmip -1
  • Avatar of GameDev
  • [QUOTE=Unisath;36585766]Another random question: How do I change the color of a hat? Does it have something to do with the element viewer?[/QUOTE] If it has a skin you can change it in the element viewer, i don't think you can change the color manually though.
  • Avatar of ElementalCreeds
  • [QUOTE=Bitl;36586369]I found a fix for the fullbrighted graphics. Put this in the console: mat_picmip -1[/QUOTE] Didnt seem to work for me, I mean like, The graphics once im recording look nice, In the camera and editing, They're bad.
  • Avatar of Bitl
  • [QUOTE=ElementalCreeds;36586489]Didnt seem to work for me, I mean like, The graphics once im recording look nice, In the camera and editing, They're bad.[/QUOTE] Try mat_picmip -3 then
  • Avatar of FunnyStarRunner
  • There's a white line going diagonally across my screen. As far as I know, the only way to get rid of it is to check "Show Ambient Occlusion" under the render settings. But when I do that, the screen freezes until I uncheck it.
  • [QUOTE=Bitl;36586497]Try mat_picmip -3 then[/QUOTE] it's at -10 per default, lol
  • Avatar of GameDev
  • [QUOTE=FunnyStarRunner;36586716]There's a white line going diagonally across my screen. As far as I know, the only way to get rid of it is to check "Show Ambient Occlusion" under the render settings. But when I do that, the screen freezes until I uncheck it.[/QUOTE] Do you meet the minimum specs? Maybe its a graphics issue, shot in the dark.
  • Avatar of geogzm
  • You can turn yourself in to a black silhouette if you disable particles. Works for me. [editline]2nd July 2012[/editline] Why do I lag on every map that isn't a default map? How do I fix this?
  • Avatar of uitham
  • [QUOTE=geogzm;36587219]You can turn yourself in to a black silhouette if you disable particles. Works for me. [editline]2nd July 2012[/editline] Why do I lag on every map that isn't a default map? How do I fix this?[/QUOTE] I get 0.5 fps on half of the maps, excluding koth_nucleus and 2fort (Didn't test any others, but lumberyard and barnblitz do the 0.5 fps thing)
  • Avatar of Sinic
  • Does creating a server for multiplayer actors require doing anything for preparations like boosting ports, etc.? Or does it work another way? (I don't have SFM, but I'm just wondering. :U)
  • Instead of manually removing every stupid entity that was "double" recorded (doors, medipacks, supply closets, the nucleus generator thing) is there a way to properly do this? I tried unselecting entities from the record dialog but this does not seem to help.