• SFM thread V2
    2,037 replies, posted
Do I have to convert her textures or anything?
Yeah. And remove the $yellow line in the vmts.
How do I fix the black player models? I used the file from the GMod website, but I don't think that will apply to Fem-Scoot. [editline]09:43PM[/editline] By the way, Met, I added you on Steam :buddy:
That's done by removing the $yellow line. Edit: Added!
[url]http://dl.dropbox.com/u/3797244/JF_1.mp4[/url] Just testing some more facial animation/lipsync stuff out :)
jesus christ there's a whole lot you can do with the dme editor for example record yourself doing something and search for rimlight play with rimlightboost and you can change how strong the rimlighting is of course it looks just fine as it is but it's nice to know just in case you need it for some reason! edit: probably not a good idea to play with phong since it just crashes on me every time edit 2: there's also some settings for cloaking (which should be obvious since it's in the vmts) and you can change how much the model is cloaked [img_thumb]http://img59.imageshack.us/img59/1079/headvy.jpg[/img_thumb] headvy
[QUOTE=Metroid48;22089632]I've been trying to get hats: [img_thumb]http://img517.imageshack.us/img517/7748/tf2sfmhattest.jpg[/img_thumb] Still not a whole lot of luck. The hats follow the puppet(s) around but rotate on the spot, not around the base of the puppet, so they end up disconnected. If you have a character running in a straight line it's ok I guess :v: Hoping to work this out eventually.[/QUOTE] You do know it's hearing protection gear, and not a headset, right?
[QUOTE=Clavus;22098833]You do know it's hearing protection gear, and not a headset, right?[/QUOTE] Does it matter? He's just trying to import hats
I've done my first animation/facial expression test ever on a T posed model inside SFM. [media]http://www.youtube.com/watch?v=t44E_2SGTLQ[/media] [editline]03:16PM[/editline] It's awesomely rubbish. Basically I took 6 seconds range of the video, the face expression and hand changing position is 1 second long over 4,5 different instances. For my next try I'll use 0.5 of a second maybe this will bring better effects, and random body shaking so the model will not look stiff while standing.
Looks like food's on his brain.
Do you guys know how to change the models skin from red to blue? I always spawn it and it's red and I need a blue one.
[QUOTE=Appolox;22102532]Do you guys know how to change the models skin from red to blue? I always spawn it and it's red and I need a blue one.[/QUOTE] So even if you spawn as the blue team, you're red?
Easy enough to change. Find the model with the Dme editor and change "skin" to 1. I'll get a screenshot in a minute. This is also where you remove default hats by the way - by changing the bodygroup property. [b]Edit:[/b] [img]http://thefwcentral.com/upload/content/images/tf2_sfmSkinsbd99e22.jpg[/img] The specific location is [i]clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/scene/children/take*/children/player_NAME/children/player_NAME_World Models/children/MODEL[/i], but as you can see I just searched "pyro" to get to it.
[QUOTE=Metroid48;22103027] The specific location is [i]clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/scene/children/take*/children/player_NAME/children/player_NAME_World Models/children/MODEL[/i], but as you can see I just searched "pyro" to get to it.[/QUOTE] By the way, searching is the only way for me, because if I just browse I only get ..._Channelclip in which I can't change much.
There's two locations that have similar children. One is [i]clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/scene/children/take*/children[/i] and the other is [i]clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/trackGroups/take*/tracks[/i]. The first is for the actual models and bone hierarchy. The second is where it stores all the animation frames and the channels which copy the values around to the correct location.
[img]http://i48.tinypic.com/furdx.jpg[/img] I does not work for some reason.
[QUOTE=Metroid48;22103027] [IMG]http://thefwcentral.com/upload/content/images/tf2_sfmSkinsbd99e22.jpg[/IMG][/QUOTE] Changing that number to 2 or 3 gives them ubercharge skin, pretty cool
Looks like you're editing the animationSets copy. You probably need to edit the model's actual value, in the location above. Or just cycle through a few more search results!
[QUOTE=Metroid48;22103574]Looks like you're editing the animationSets copy. You probably need to edit the model's actual value, in the location above. Or just cycle through a few more search results![/QUOTE] Checked them, and still does not work. [editline]06:00PM[/editline] I have checked in 'scene' and 'animationSets'.
I'll give it a test then with animation sets enabled. There might be a channel that's overriding the value with a logged value. Also, was just trying something with the sniper and found that the medic's domination lines seem to have replaced his. Likely my mistake (though not sure how), but funny nonetheless. [b]Edit:[/b] Got it. It's exactly what I expected - a channel logged a single skin value and is then overriding the version in all other locations. I expect that you could change the value, [i]then[/i] add an animation set and it'd work, but it's easy enough to do even after adding the animation set. I'll write up a full tutorial in a minute as the explanation is a bit long.
[QUOTE=Metroid48;22103809]I'll give it a test then with animation sets enabled. There might be a channel that's overriding the value with a logged value. Also, was just trying something with the sniper and found that the medic's domination lines seem to have replaced his. Likely my mistake (though not sure how), but funny nonetheless. [b]Edit:[/b] Got it. It's exactly what I expected - a channel logged a single skin value and is then overriding the version in all other locations. I expect that you could change the value, [i]then[/i] add an animation set and it'd work, but it's easy enough to do even after adding the animation set. I'll write up a full tutorial in a minute as the explanation is a bit long.[/QUOTE] Thank you, it is another step forward for me and for many at this point. [editline]06:52PM[/editline] I'm gonna wait for tutorial.
Hmm. I've come across a bit of a problem. Whenever I start up SFM, I'm greeted by a dialogue box that reads [quote=Dialogue Box] The procedure entry point ?TryLock@CThreadFastMutex@@QCE_NXZ could not be located in the dynamic link library tier0_s.dll[/quote] SFM then crashes soon after. This has happened to me multiple times. Anyone know what's up?
[QUOTE=Markntosh;22104859]Hmm. I've come across a bit of a problem. Whenever I start up SFM, I'm greeted by a dialogue box that reads SFM then crashes soon after. This has happened to me multiple times. Anyone know what's up?[/QUOTE] Looks like a corrupted .dll file?
This will also be of use to other people, so listen up! If you don't care about the (short) explanation just follow the navigation prompts two paragraphs down. When you add an animation set to a player model, it creates a lot of channels. Channels are effectively elements that record a list of time-value pairs, which are frames of animation. They are stored in ChannelsClips, which are the things you are actually looking at when you zoom in on a shot. They constantly copy these values to another element. You can easily add new value pairs to this list, meaning you can manually animate values such as the character skin (ex. toggle uber effects without a medic), the position, or really anything you can see in the Dme editor. Manual animation can be tedious, but it's perfectly possible. This is in fact exactly what the Animation Set Editor is changing - technically an animation set is just a specialized version of all this! [img]http://thefwcentral.com/upload/content/images/tf2_sfmChannels_335fe8dd.png[/img] In this case we have a spy model that was added via Create Animation Set. Navigate to [i]clipBin/sequence/subClipTrackGroup/tracks/Film/children/shot/trackGroups/[/i]. This is where the track groups are stored - the one you want is [i]channelTrackGroup[/i]. Expand it, then [i]tracks/animSetEditorChannels/children[/i]. Then expand the name of the animation set (ex. "spy"). Then [i]channels[/i]. In here, you'll find [b]EVERY[/b] bit of animation data for that model, including some pieces you can't access with the animation set editor. Scroll down to "models\player\spy_skin channel" and expand it. Then expand [i]log\layers\int log\values[/i] and there should be one entry. Change it to whatever you want the skin to be. [img]http://thefwcentral.com/upload/content/images/tf2_sfmChannels_196cfee5.png[/img] [img]http://thefwcentral.com/upload/content/images/tf2_sfmChannels_2cf8ee8f.png[/img] Want to have easier access to the skin value? Delete the "models\player\spy_skin channel" channel and you [i]should[/i] be able to edit the DmeGameModel's skin value again, as it's no longer being overridden. Want to make the skin change during the recording? Right click times->Add Item. Right click values->Add Item. Then just change them accordingly. Note that the times are in tenths of thousandths of seconds - that is, 10000 = 1 second. Why they didn't choose milliseconds I don't know. Want to animate values that aren't already setup? You'll have to add the channel manually. It's easy, but I'm out of time right now so I'll do a write up later.
[QUOTE=Anti Christ;22104888]Looks like a corrupted .dll file?[/QUOTE] Guess I should just re-install, then.
[QUOTE=Markntosh;22105591]Guess I should just re-install, then.[/QUOTE] Well I'm just sort of guessing. But since it says it's the .dll that's messing it up, something bad happened. So if you're gonna reinstall it, I'd make a different install, so you can still tinker with the broken one and see if you can find out what changed. It might be something good, it might be nothing. Who knows?
I'll just comment that I get the same dll message sometimes when starting. It's stopped recently, but even when it was appearing SFM continued to work fine, so that may not be the cause of your crashes.
Oh what the hell :saddowns: I've finished creating my movie earlier today and decided to render it tonight. I launch SFM and see broken spawn door and flaming textures on my characters! Everything was great in the morning :argh:
[QUOTE=RivaGe;22107119]Oh what the hell :saddowns: I've finished creating my movie earlier today and decided to render it tonight. I launch SFM and see broken spawn door and flaming textures on my characters! Everything was great in the morning :argh:[/QUOTE] If you saved it, and closed SFM, then reopened the project, that's probably why. I've had nothing but issues with saving projects, so I have to do the entire thing without closing SFM whenever I make anything.
Wow it's broken completely, lips don't move and all of my custom animations are gone. [B]Sweet![/B] [editline]11:46PM[/editline] automerge broken as well!
Sorry, you need to Log In to post a reply to this thread.