• My entity is not appearing in it's entities tab.
    4 replies, posted
I'm working on a custom entity for GMOD. I can not find my entity in its entities tab. Here is the shared.lua [code] ENT.Type = "anim" ENT.Base = "base_gmodentity" ENT.PrintName = "Custom_Money_Printer" ENT.Spawnable = true ENT.Category = "darkrp" ENT.Author = "saur1" ENT.Contact = "test" ENT.Purpose = "test" ENT.Instructions = "test" ENT.Category = "darkrp" [/code] init.lua [code] AddCSLuaFile("cl_init.lua") AddCSLuaFile("shared.lua") include("shared.lua") function ENT:Initialize() self:SetModel("models/props_c17/consolebox03a.mdl") self:PhysicsInit(SOLID_VPHYSICS) self:SetMoveType(MOVETYPE_VPHYSICS) self:SetSolid(SOLID_VPHYSICS) local phys = self:GetPhysicsObject()          if phys:IsValid() then     phys:Wake()     end end [/code] and cl_init.lua [code] include("shared.lua") function ENT:Draw() self:DrawModel() end [/code] file directory - F:\SteamLibrary\steamapps\common\GarrysMod\garrysmod\lua\entities\custom_printer
EDIT: Okay now gmod isn't showing ANY of my custom files, including my SWEPS
Can you go to steam library, select Garry's mod, go to properties, local files and see if that's really the path (it once changed my library to C drive)
correction: its now C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\garrysmod\lua\entities\customent but this isnt the issue as I just reinstalled my game after making that post to see if that fixed it, and it didnt. I still can not find my entity under its tab UNLESS I move it under the addons folder (but then the model would show up as an error)
SOLVED: My dumb ass misspelled "init.lua" in the garry's mod directory. I can now spawn it on my spawn menu.
Sorry, you need to Log In to post a reply to this thread.