• HDR Compile Error: Access Is Denied (Hammer)
    4 replies, posted
I'm trying to compile the HDR for my map so that lighting looks right, but whenever I compile the map I get the following error: ** Executing... ** Command: HDR Full compile -final ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\bin\vrad.exe" * Could not execute the command:    HDR Full compile -final "C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\bin\vrad.exe" * Windows gave the error message:    "Access is denied." I've tried setting Hammer and vrad to run in administrator, and have confirmed that vrad.exe is not read-only, but I still get the same error. What should I do?
are you using hammers f9 or a batch file?
The former, I'm exporting my map from Hammer.
Your settings appear wrong. Command should have the path to VRAD and Parameters should have -final like so: ** Executing... ** Command: "<redacted>\bin\vrad.exe" ** Parameters:  -game "<redacted>\garrysmod" "<redacted>\Mapping\gm_shitsticks\gm_shitsticks"
So my settings were wrong, as I got the "HDR Full compile" bit from the Valve Developer Wiki, but I mistook the compile preset for an option. Thank you for your help, and sorry for wasting your time on such a foolish mistake.
Sorry, you need to Log In to post a reply to this thread.