• Server FPS drops to almost zero
    0 replies, posted
I recently updated to Windows 10 1809 by doing a complete reinstall. Now my dedicated server, which used to run just fine with a lot of moving things, cannot support even two colliding barrels on some maps. I have and FX-8350 processor. I did not change anything in the server installation, did not even touch the server directory. This same server installation runs just fine on another PC with a much slower CPU(Athlon II), so I think that it is not the amount of addons on the server what causes performance issues. I tried to run different branches, did not change anything. Procexp does not show anything unusual, there's not a lot of I\O, CPU load is minimal, a lot of free RAM. Bu-u-u-ut, when SRCDS performance drops it is not utilizing even half of a core. And SRCDS is mostly single-threaded, right? What is even more strange for me is that the performance drop is not linear. To me it looks like when the entity count exceeds a certain threshold server's fps immediately drops to 2. On flatgrass I can spawn a couple of ACF-powered car suspensions before performance drops, but metrostroi maps, which already have a lot of entities, cause a performance drop right after loading. Typing in the server's window is also visibly slow. Are there any Garry's Mod-SRCDS specific tools to help find what causes low performance? I have Comodo's firewall and HIPS installed, but no antivirus. I tried turning those off, did not help a all, but then again, everything was fine before I reinstalled windows. Windows Defender is running. I tried assigning the server to different CPU cores. I also moved the server to an SSD and tried to set up a new server from scratch. With a bare minimum of addons I can spawn somewhat more contraptions before server's FPS tanks to zero. I run the server very rarely, but I think that the only thing that changed between when server was fine an now is that I added one more SSD to my machine and I reinstalled windows. With how unexpectedly Windows handles some things I am more inclined to think that this is Windows somehow throttling SRCDS and not the server itself running badly, or a hardware problem. Is there something similar to linux's cgroups in Windows? Maybe I somehow unknowingly configured a resource usage limiter? I did configure a lot of group policies after installing windows, but all of those were Windows Update related. On my previous windows installation I also disabled spectre and meltdown protection. I think I also did on this system.
Sorry, you need to Log In to post a reply to this thread.