• Getting a Compile Error
    2 replies, posted
I have been working on a map, strangely ive gotten an error not letting me run the map and changes wont show on the actual map. ** Executing... ** Command: "D:\SteamLibrary\steamapps\common\GarrysMod\bin\vbsp.exe" ** Parameters: -game "D:\SteamLibrary\steamapps\common\GarrysMod\garrysmod" "e:\!spectre\maps\vmex\rp_baserg_haz_v2_d" Valve Software - vbsp.exe (Dec 15 2018) 8 threads materialPath: D:\SteamLibrary\steamapps\common\GarrysMod\garrysmod\materials Loading e:\!spectre\maps\vmex\rp_baserg_haz_v2_d.vmf ConVarRef mat_reduceparticles doesn't point to an existing ConVar Can't find surfaceprop marble for material AGENCY/FLOOR/MARBLE01A, using default Can't find surfaceprop marble for material AGENCY/WALL/MARBLE01, using default Error! Variable "$surfaceprop" is multiply defined in material "pk02/pk02_rock01_dirtfloor005b_blend"! Error! Variable "$surfaceprop" is multiply defined in material "pk02/pk02_rock01_dirtfloor005b_blend"! Brush 14466: MAX_MAP_BRUSHSIDES Side 5 Texture: METAL/METAL_EXT_11 ** Executing... ** Command: "D:\SteamLibrary\steamapps\common\GarrysMod\bin\vvis.exe" ** Parameters: -game "D:\SteamLibrary\steamapps\common\GarrysMod\garrysmod" "e:\!spectre\maps\vmex\rp_baserg_haz_v2_d" Valve Software - vvis.exe (Dec 15 2018) 8 threads reading e:\!spectre\maps\vmex\rp_baserg_haz_v2_d.bsp Error opening e:\!spectre\maps\vmex\rp_baserg_haz_v2_d.bsp ** Executing... ** Command: "D:\SteamLibrary\steamapps\common\GarrysMod\bin\vrad.exe" ** Parameters: -both -game "D:\SteamLibrary\steamapps\common\GarrysMod\garrysmod" "e:\!spectre\maps\vmex\rp_baserg_haz_v2_d" Valve Software - vrad.exe SSE (Dec 15 2018)       Valve Radiosity Simulator      8 threads [Reading texlights from 'lights.rad'] [45 texlights parsed from 'lights.rad'] Loading e:\!spectre\maps\vmex\rp_baserg_haz_v2_d.bsp Error opening e:\!spectre\maps\vmex\rp_baserg_haz_v2_d.bsp ** Executing... ** Command: Copy File ** Parameters: "e:\!spectre\maps\vmex\rp_baserg_haz_v2_d.bsp" "D:\SteamLibrary\steamapps\common\GarrysMod\garrysmod\maps\rp_baserg_haz_v2_d.bsp" The command failed. Windows reported the error:   "The system cannot find the file specified." Im not sure if its something to do with the materials as it did say $surfraceprop This is the VMT for that material. "worldvertextransition" { "$basetexture" "pk02/pk02_rock01_C" "$basetexture2" "nature/dirtfloor005b" "$surfaceprop" "rock" "$surfaceprop" "dirt" }
Brush 14466: MAX_MAP_BRUSHSIDES That's your error. Your map apparently has too many brushsides. Maybe you should use Havok's compilers to push back those limits.
Alright ill try it out
Sorry, you need to Log In to post a reply to this thread.