• Missing Addons And GMA Files
    8 replies, posted
I've sent ticket to facepunch but im also concerned that this may be an issue with connectivity to the workshop ect. Im missing .GMA files, They dont appear in any of the folders and I have checked through everything to do with steam in my directory to no avail. I copy and pasted my concern from a thread that no one seems to have a full answer for and says its either up to you guys or facepunch. Ples help I really want to be able to get the content I paid my money for. I'm almost fed up with this, quick story for ya I buy Gmod Launch it up Download Mods Enable mods Start New game Only 2 maps available wtf they're the default ones Go back to addon store disable and enable mods go back to start new game nothing there but default maps, Curious too see if gun mods installed launch default map no addons there either go back to menu enter steam workshop I'm subscribed to all of them and they're enabled  Unsubscribe to mods and exited the game, restarted PC Launched gmod Redownload mods go to start new game default maps.  launch default map none of my other addons were in there this time either flip table drink boiling water exit game look at threads people have this issue but their issue is similar but different at the same time try their solutions anyways List as Follows Go to Local directory and messed with some files, deleted addon file and data caches-dident work Validated game files-dident work factory reset option in files-dident work Uninstalled and reinstalled game- Dident work Restarted computer- Dident work, Turned off cloud saving-dident work Cried-Dident work Prayed to baby jesus-dident work Looked up how to fix my issue- None worked Did all of the above in different and certain orders-Dident work Deleted all folders and reintalled the game-Dident work Tried offline mode-Dident work Ok I am at a loss here like in the addon menu AND steam workshop im subscribed and installed to what I download, Thing is, I cant play with anything but the default stuff,  Some sidenotes Joined a Multiplayer sanbox server and it worked fine, I suddenly had access to server mods like AK-47's and stuff but when playing singleplayer none of thats the case Im not sure but the mods are in one of the file caches for the workshop file in my directory, but not in the gmod file titled addons itself wth I need help cause im this close too losing my marbles boiz Thanks in advance-Been having this problem for a couple days now (EDIT- The .GMA files are not even downloaded into the Addons folder and they dont seem to be going anywhere else) EXTRA EDDIT Steam couldn't find a solution so they sent me here for answers and so did facepunch so here I am world. Ok so basically STORY TIME Been stranded a long time in the realm of forums and non working solutions Really want to mess around with mods but to no Avail even though its been a week of actively trying to find a solution Some nice community moderators on steam attempt to help me out but had no solution themselves Said, "Ya I'm at a loss, This is up to steam/Facepunch" Summit original thread with a few edits through a ticket for support Facepunch tells me to go ask Steam Steam says go ask facepunch or talk to more moderators Surprise Email from Facepunch Says post here and see if i can find some help Is now here So quick summary of my problem that's up to Date So basically Found out my GMA files arnt even in My addon folder NEWS FLASH GMA FILES ARNT ANYWHERE I can download addons They'll do the download thing It completes For example I download BigCity The thing isent even in my start new game menu, nor anywhere in my Directory says I'm subscribed, do the usual, Uninstall, steam cloud stuff, Messing with files, Offline mode, nuke anything to even do with Gmod, reinstall, Nothing works Just recently Messing with launch Parameters, And checked to see if my firewall was blocking anything*(It Wasn't)* Validated Caches and the game in general and it thinks things are fine but their not fine. Side notes to keep in mind, Reinstalling Mods that have been downloaded and rid of in the past instantly download again when I press subscribe. I am not a techy guy onceover just desperate so if you ask me to check out my JOPLIN.X&JSAU//RecourceEdit.208s523rSA9 I will die from a stroke So please someone help me, I'm out of hope and ten bucks
Post console log
How do I do that Exactly
Press SHIFT+ESC and copy everything from the window that appears.
Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\105982362' Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\1577310997' Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\1605334558' Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\1616770358' Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\1620790122' Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\302261460' Adding Filesystem Addon 'd:\ steam\steamapps\common\garrysmod\garrysmod\addons\815782148' Initializing Awesomium.. Parent cvar in server.dll not allowed (p2p_enabled) --- Missing Vgui material hud/leaderboard_dead No Kinect SDK "~" isn't a valid key Unknown command "spawnmenu_icon_precache" Host_WriteConfiguration: Wrote cfg/config.cfg --- Missing Vgui material vgui/servers/icon_replay --- Missing Vgui material vgui/servers/icon_replay_column Host_WriteConfiguration: Wrote cfg/config.cfg Stopping Awesomium.. Done! Shutdown function ShutdownMixerControls() not in list!!! There you go
Get rid of the space in the file path to the game. d:\ steam\stea ^ this right here
"The source and destination files are the same" and it makes me cancel my change so it can revert back to having the space
Rename it to Steam2 and then back
It Worked Chief, Thanks a bunch, Had to reinstall steam to get the file to work but it was overall worth it, Hope this works for others dealing with the same issue
Sorry, you need to Log In to post a reply to this thread.