• Sending Client Info
    4 replies, posted
Alright, so I know you will say to reinstall Gmod, or delete addons or something of that nature. I've removed all addons, reinstalled Gmod, restarted my computer, moved the game to a different hard drive, I've even tried deleted different file directories inside the Gmod folders looking for something related. My internet isn't the issue. I had this issue a few weeks ago and I couldn't figure it out, then it worked for a few days; but now its back to not working. https://files.facepunch.com/forum/upload/409436/4cf84560-a211-4f91-a65b-9015ff84f6de/3913b6e441314afebea2a734e86bf47b.png
You have to wait for the Lua files to finish downloading. This is only necessary to do once per server.
I've at one point left it on for 6 hours.
I find that hard to believe. You would've been kicked by the server's timeout. Anyway, switch to the Dev branch and see where you get stuck on there: https://wiki.garrysmod.com/page/Dev_Branch Also tell me if the loading screen is frozen or not when you are stuck. The cancel button will change its colors when you hover over it with your cursor if it is not frozen. Also a console log after you gave up on waiting might be helpful too (SHIFT+ESC to open console)
The same thing was happening to my friends when they were trying to join in my server. I was the reason that they stuck, but after i re-installed all addons it worked. (I deleted all of my addons and added them again from my collection)
Sorry, you need to Log In to post a reply to this thread.