• Lua issue with joining ANY server on garrys mod
    5 replies, posted
When I join ANY server on Garry's mod regardless of what gamemode it is. I cannot join, It says on the loading screen AFTER client info has been sent and it stays there forever. It says variations of things like "ICLE lua files from server..." or "4 lua files from server..." or just "lua files from server..." Photos for reference here: https://imgur.com/a/0g0qPFh here are photos from console on what is happening when I attempt to join: https://imgur.com/a/XEk20ho Here are things I've done already to try and solve this issue. 1. restart my computer 2. restart garry's mod 3. Uninstall and remove ALL addons from garry's mod. 4. Verified my game files 5. I am NOT opted in any beta programs. Not even chromnium. 6. I have no launch options 7. I uninstalled garry's mod and all related content to garry's mod from my C: and D: Drives. 8. I uninstalled Steam from my C: and D: drives. 9. Purged ALL content related to steam or any games that didn't uninstall correctly from BOTH C: and D: drives. 10. I reinstalled Steam on ONE drive. My D: drive.. 11. I set the path correctly for Steam on my D: drive 12. Reinstalled Garry's Mod on the D: drive through the correct path 13. Did steps 7-12 TWICE and nothing has changed. 14 Disable ANY and ALL anti virus and firewall. Attempted to join the servers. Same result nothing. 15 Ran the game in DEV mode. Nothing changed. I dont know what to do guys. if anyone could help PLEASE!!! Thank you!
having the same issue
Tried VPN?
In your gmod install directory (steam/steamapps/common/Garry's Mod/) there should be a .bat file called FactoryReset-GMod.bat (if not then add my discord, Dragon#7312, and I would be more than happy to send it your way), run it and click Y on your keyboard and it resets gmod to factory defaults (doesn't delete addons) and resets settings and clears server data. After running it, go to your server you want to play and it should work. Cheers & Enjoy!
Didnt work for me, really annoying i tried everything.
Can you please screenshot the loading screen on the Dev branch for me? Especially on that Civil Gamers server, maybe even several different times, it shows something weird and I want a confirmation.
Sorry, you need to Log In to post a reply to this thread.