• [LUA ERROR]Pointshop2
    3 replies, posted
The pointshop2 works without problems when it's the normal version but when I change it to chromium it shows those errors: [ERROR] addons/pointshop2/lua/ps2/client/icons/cl_dcsgoitemicon.lua:29: attempt to call field 'RequestIcon' (a nil value)   1. SetItemClass - addons/pointshop2/lua/ps2/client/icons/cl_dcsgoitemicon.lua:29    2. SetItemClass - addons/pointshop2/lua/ps2/client/cl_dpointshophaticon.lua:29     3. DoPopulate - addons/pointshop2/lua/ps2/client/tabs/management_tab/manage_items/content/cl_pointshop2content.lua:118      4. PopulateWithExistingCategories - addons/pointshop2/lua/ps2/client/tabs/management_tab/manage_items/content/cl_pointshop2content.lua:260       5. fn - addons/pointshop2/lua/ps2/client/tabs/management_tab/manage_items/content/cl_pointshop2content.lua:348        6. Call - addons/ulib/lua/ulib/shared/hook.lua:109         7. CallPopulateHook - addons/pointshop2/lua/ps2/client/tabs/management_tab/manage_items/dpointshopcontentpanel.lua:27          8. Init - addons/pointshop2/lua/ps2/client/tabs/management_tab/cl_dpointshopmanagementtab_items.lua:15           9. Create - lua/includes/extensions/client/panel/scriptedpanels.lua:37            10. Init - addons/pointshop2/lua/ps2/client/tabs/management_tab/cl_dpointshopmanagementtab.lua:19             11. Create - lua/includes/extensions/client/panel/scriptedpanels.lua:37              12. Init - addons/pointshop2/lua/ps2/client/cl_dpointshopframe.lua:112               13. Create - lua/includes/extensions/client/panel/scriptedpanels.lua:37                14. OpenMenu - addons/pointshop2/lua/ps2/client/cl_0_pointshop2.lua:7                 15. ToggleMenu - addons/pointshop2/lua/ps2/client/cl_0_pointshop2.lua:69                  16. unknown - addons/pointshop2/lua/ps2/client/cl_pointshop2view.lua:80 and I need to do this, otherwise the jukebox doesn't work. Thanks for helping me!
I am confusion, [LibK] Loading SHARED file: 0_sh_middleclass.lua  [LibK] Loading SHARED file: 1_sh_promises.lua  [LibK] Loading SHARED file: 2_sh_libk.lua  [LibK] Loading SHARED file: sh_KPlayer.lua  [LibK] Loading SHARED file: sh_Singleton.lua  [LibK] Loading SHARED file: sh_addonloader.lua  [LibK] Loading SHARED file: sh_debug.lua  [LibK] Loading SHARED file: sh_easing.lua  [LibK] Loading SHARED file: sh_logger.lua  [LibK] Loading SHARED file: sh_permissionInterface.lua  [LibK] Loading SHARED file: sh_thirdparty.lua  GLib : Adding glib/* to virtual lua pack... done (228 total files, 571.04 ms)  LibK uses vnet by vercas (Copyright 2014 Alexandru-Mihai Maftei), MIT licensed  [LibK] Loading SHARED file: sh_underscore.lua  [LibK] Loading SHARED file: sh_util.lua  [LibK] Loading SERVER file: sv_database_transaction.lua  [LibK] Loading SERVER file: sv_libk_BaseController.lua  [LibK] Loading SERVER file: sv_libk_config.lua  [LibK] Loading SERVER file: sv_libk_database.lua  [LibK] Loading SERVER file: sv_libk_model.lua  [LibK] Loading SERVER file: sv_libk_player.lua  [LibK] Loading SERVER file: sv_libk_server.lua  HTTP failed - ISteamHTTP isn't available!  [LibK] Loading SERVER file: sv_libk_util.lua  [LibK] Loading SERVER file: sv_permissionInterface.lua  [LibK] Loading SERVER file: sv_versioning.lua  [LibK] MANUAL: Loading file: libk/shared/sh_KPlayer.lua  LibK by Kamshak loaded  [PAC3] Loaded total 36 particle systems  Pointshop2 Version 596 : 76561198214992071 loaded  So as you can see, that everything is loaded, LibK, Pac3 and Pointshop 2 from your leak. Good, but then when I am ingame, I wanted to open Pointshop2 with F3 and nothing appears. And I checked the server console and it said: L 04/19/2019 - 17:38:00: "Chinese Boi<2><STEAM_0:1:200391905><>" entered the game  [Chinese Boi|2|STEAM_0:1:200391905] Lua Error:  Couldn't include file 'libk\3rdparty\\luadata.lua' (File not found) (@addons/libk/lua/libk/shared/sh_thirdparty.lua (line 9))  [Chinese Boi|2|STEAM_0:1:200391905] Lua Error:  Couldn't include file libk/3rdparty/luadata.lua -> libk/3rdparty//luadata.lua: Unknown Error  [Chinese Boi|2|STEAM_0:1:200391905] Lua Error:  Couldn't include file 'libk\3rdparty\\von.lua' (File not found) (@addons/libk/lua/libk/shared/sh_thirdparty.lua (line 9))  [Chinese Boi|2|STEAM_0:1:200391905] Lua Error:  Couldn't include file libk/3rdparty/von.lua -> libk/3rdparty//von.lua: Unknown Error  [Chinese Boi|2|STEAM_0:1:200391905] Lua Error:  Couldn't include file 'libk\3rdparty\\circular_queue.lua' (File not found) (@addons/libk/lua/libk/shared/sh_thirdparty.lua (line 9))    Yeah, thats basically it. I would really really appreciate your help if you want to help me. I tried to reinstall LibK and Pointshop2 but nothing works. I sat 4 hours down on the PC to fix the problem. Please help me. I am not a leecher just because I created an account and looking for leaked addons, I need help from users that are experienced. I googled and so on and searched for answers but the results were always nothing. I tried with the LibK on Github but it has other Lua Errors.. So I am so confused and I am searched help for soo long, so I decided to post here my thread. Thanks for reading, Chinese Boi
It seems that the API for pointshop2 is down and this issue essentially means we cant fix this error until is back online. It was hosted here https://www.pointshop2.com/
I found a fix if you are a license buyer please join the ps2 discord otherwise gg. Ticketeer join that and join the discord and message Dimento
Sorry, you need to Log In to post a reply to this thread.