• Computer suddenly not booting
    11 replies, posted
First some quick specs FX-8320 R9-390x ga-78lmt-usb3 CX500 A few days ago I was playing a game when my computer suddenly shut off. At first I figured it was a weird crash but then my computer wouldn't turn back on. Today I finally got a moment to sit down a take a look, I figured the psu had given up and after some quick reading online found a test to see if a psu was dead using a paper clip. When I tried this I can hear the psu starting up. Does this mean the issues is elsewhere or could the problem still be the psu? I figured I'm going to have to replace some parts, I'm just not sure what. Any help would be appreciated, if you need any more information I should be able to provide it
It could totally still be the PSU, my own one died in a similar way recently - it would start if I unplugged the big connector from the motherboard and shorted the green wire with ground, but wouldn't show any signs of life if it was plugged into the motherboard. Thankfully I had another (weaker) PSU on hand which allowed me to rule out the motherboard being the culprit
Reseat your memory and cable connections. If you have a spare PSU, even if it's wimpy for an FX8xxx and 390x, try it just to see if it boots. You could also throw the CX500 in another computer. If it still doesn't boot, it's likely a motherboard or CPU. The Corsair CX series suck hard, so that's your best case repair, unless it killed other hardware.
I've tried restating the memory and the plugs. No good. I'm trying to find a spare psu around to test the rest of the setup
Chances are unless you have another home-built rig any PSU you find will be like 250-350W so your best bet is to take the CX and put it in the spare machine and see if it works. Since it stays on with the paperclip trick, the chances of your board or CPU shitting the bed are higher since they might not be signalling the PSU correctly
Question: what happens when you hit the power button? any lights/fans/beeping?
Nothing, I've double checked the wiring to the bottom though and there are no obvious issues
I’ll have to echo the users above and suggest testing a known good power supply. Which is a shame, it’s likely the hardest thing to swap out.
Alright I managed to find a coolermaster masterwatt 750, after hooking it all up no dice. Still nothing when I hit the power button. Is it fair to assume the mobo is done?
Probably. Have you looked for any signs of physical damage like blown capacitors or burn marks near the CPU VRMs?
Its weird there's nothing visible. I'm going replace the board, I've been wanting move to ryzen for a while and the old board had the wrong socket so I would have needed a new one anyway.
Sorry, you need to Log In to post a reply to this thread.