• Open Ports Cannot Be Seen
    6 replies, posted
So I have a NetGear C6300BD, and I have a bunch of ports set up to be open. My IP is static and matches the port settings on the administrator page. Simple Port Tester detects them as open: https://files.facepunch.com/forum/upload/229888/8eaa6b2a-820e-46e9-9574-a3cd7eca75e0/image.png However, Open Port Check Tool cannot see these ports: https://files.facepunch.com/forum/upload/229888/ff73701c-c316-42f7-aa43-6197e71cc564/image.png Simple Port Tester confirms I have everything set up correctly, but Open Port Checker Tool also verifies my suspicion that the ports aren't actually visible. I don't know why they aren't visible, but it has definitely ruined any opportunities for me hosting local games. Anyone know anything about this shitty ass router and if this can be fixed? Let me know if you need additional info.
The port is open in your router but it may be blocked by your computer firewall or you're not actually trying to host the game when you're running the port check tool which in turn closes the game server port on your local machine.
Those port check websites never really worked for me but whenever I opened ports for apps or games it just worked fine. So did you actually check in the games if it works or not?
Yeah, I recall the reason I looked into this in the first place is because I tried hosting a game of Risk of Rain with my friends a while back and they were unable to connect to my game. I could try testing other games in a bit. I'll let you know if it works or not.
It helps to understand Transport layer protocols. You can't check if UDP ports are open because of the way that UDP is "stateless". Unlike TCP, UDP "connections" have no expectation of the server or client ever responding or even receiving it. Hope it does, but don't count on it. A packet is fired off, and may or may not make it to the destination. Does it make it? Meh, who cares. You'll never know. This is unlike TCP, where there is a handshake at the beginning explicitly to verify that server and client are communicating. There is also confirmation for every packet. However, for applications like VoIP and games, this is not preferable. It would increase latency significantly, as packets have to be verified that they were received. Its really meant for data transfer, where accuracy is paramount. So most games use UDP for actual game data. So, as a TL;DR, these port testers can't check UDP ports, because there is nothing built into the protocol to let the tester know you even received the packet. That's not to say you can't check UDP ports, but it requires you to actually check with a program that can connect to that port over UDP, so it responds correctly. Run something like Wireshark to check if the packets are actually being sent to the PC.
I'm not really sure what I'm doing with Wireshark, but I tried hosting a Synergy server while running it. To my surprise, my friend (and some random guy) was able to connect. I don't know if Synergy uses Steam's multiplayer thing, but I got this from Wireshark (of course there's a lot of this in wireshark): https://files.facepunch.com/forum/upload/229888/e15aaf7a-9e0b-495f-8beb-900a87ad6df7/image.png 27030 being the port that is forwarded. The odd thing is, when I tried hosting a Terraria server without Steam Multiplayer, my friend was unable to connect. I'm pretty sure the default port it uses is 7777, which is forwarded with UDP. Could just be there are extra steps in hosting a Terraria server that I don't remember, but if not, then it strikes me as odd that it wouldn't work.
Pretty sure you need to open 7777 TCP not UDP. Not all game ports are always UDP.
Sorry, you need to Log In to post a reply to this thread.