• Disable Scientists on Rust servers
    3 replies, posted
Does anyone know how to disable the spawning of Scientists? I'm setting up a server that's designed for PVP in teams & I need to remove all AI NPC's & AI_NPC_Enable is set to false & still doesn't work.
Enable the scientist NPCs Use the command below to enable the scientist: ai.npc_enable true On success the console will display: ai.npc_enable: "True" Disable the scientist NPCs Use the command below to enable the scientist: ai.npc_enable false On success the console will display: ai.npc_enable: "False"
ty for the help. But did you even read my post or just respond to the topic?
try nav_grid 0 (complete guess) because the above should work (Sandman's post) He got his information from: RUST Scientist Command and Variables RUST ai.npc_enable variable (2 of 2) This variable is used to enable and disable the RUST scientist NPCs on a RUST game server. This setting defaults to true. This configuration must be set up in the server start-up script in order for the scientists to populate the server. This event can impact the server’s overall performance if any of the settings are wildly configured. Keep sane defaults. Nav_Mesh setting must be enabled if you want the scientists to move/roam around the map. Note that this command does work from RCON platforms and doesn’t require being logged into the game server. Nav_grid 1 is suppose to enable pathing of scientist. FP is never clear on what certain things do. The nav_grid I got from: Enabling Scientists experimental on your vanilla server (so if 1 enables, 0 should disable) Let me know if this works I am trying to setup a server myself
Sorry, you need to Log In to post a reply to this thread.