• Rust Server not showing in Community List in game
    9 replies, posted
Last night i created a Rust Experimental Server and left it running all night. Here it is almost 10 hours later and its still not showing up in the Community or Modded List and it wont even show up as a LAN server. I port forwarded 28015 and 28016 with both udp and tcp and deactivated my Windows firewall. I can connect to the server though but i have to open the console command in game but i have to use client.connect. Thank you in advance if you can help me sort out this problem id love to get my server populated.
what did you set the server ip to? it needs to be your local machine's IP address not the one you'd see from whatismyip etc. it should look something like this 192.168.0.10 (or whatever your router assigned to you)
Im new to Server hosting how do you set the server ip? I thought when you make it it automatically sets the ip this is the guide I used and Ishouldve done it all correctly [url]http://www.rustafied.com/how-to-host-your-own-rust-server/[/url] [editline]14th January 2016[/editline] found the ip of my pc its 192.168.1.135 and im trying to connect to the server with it and its not working
I myself followed the guide through playrustHQ since i was already there checking out the admin RCON tools. server.ip 192.168.0.1 or whatever it actually is. you'll need to do that same for your RCON rcon.ip 192.168.0.1 etc etc If you've forwarded your ports, did you make sure to also set your router to give you a static ip? Set yourself to always get the ip address on your network that you are putting into those console commands. I've also had better luck in the run.bat file using +server.hostname (or whatever you're setting) rather than using a "-" [editline]14th January 2016[/editline] dont forget to set your ports that same way as the ip in the server console and then make those changes on the run.bat file too.
wait forgot to add the port but it let me connect using ip but like it still wont show on the list -_- [editline]14th January 2016[/editline] ok ill try that out thank you if i get it working ill comment what i did to fix it
i followed rusthq so now the ip should be set but its still not working so i guess my server ip is whitelisted on my firewall thats what rusthq says should be the problem so any idea how to fix that? [editline]14th January 2016[/editline] so ive opened the ports through my fucking firewall and still doesnt work -_- this is really pissing me off
ok after taking a break i came back and found a video on how this guy made it work for csgo and i never thought about this but i have a modem/router combo and i have a seperate asus router so after connecting my computer to the modem/router combo and setting the static ip and port forwarding again plus allowing the rustdedicated.exe and ports through the firewall it finally popped up on the server list :D
Does the server not actually save things like maxplayers or server name in the cfg? I notice in every launch .bat example they're specified in the command line, and where they were set in console, and the server was reset, return to default.
[QUOTE=emly;49534491]Does the server not actually save things like maxplayers or server name in the cfg? I notice in every launch .bat example they're specified in the command line, and where they were set in console, and the server was reset, return to default.[/QUOTE] You need to keep your settings in the .bat file or create a file called server.cfg in the /server/cfg folder. Keeping everything in the .bat is a lot smoother as there is no chance of it fucking up.
Sorry, you need to Log In to post a reply to this thread.