• Can't Launch Rust - Nothing Happens After EAC Loads
    3 replies, posted
Hey everyone, I'm completely stumped. I played Rust just fine last week, but when I start Rust from Steam, this happens: 1) The Rust logo pops up, Easy Anti-Cheat starts to load 2) The blue loading bar fills, the logo closes 3) My Steam name goes green for a few seconds (like I'm in a game), then it goes blue. Nothing. ​ There's many posts over the past couple years with the same problem. So far I've tried: Unplugging my headphone/disabling sound in Windows (weird, but it works for some apparently) Verifying Rust game files in Steam Running in windowed mode (via launch options) Reinstalling/repairing/deleting EAC Opening Rust.exe from files, not Steam (nothing happens) Running everything I can think of as administrator Running in different compatibility modes (Win 8, Win 7) Reinstalling Rust Reinstalling Steam The only way Rust will run is if I force OpenGL via the launch options (though performance is terrible). Rolling back GPU drivers didn't work. The only thing I haven't tried in reinstalling Windows, which I've heard is a last resort (I'd rather not). I'm normally pretty good at googling computer problems and fixing them, but this is on another level. My specs: i7-3770k, AMD 7970, 16 GB of ram, SSD (tried on HDD too), Windows 10 64-bit Thanks!
Moved to help subforum. Hopefully someone from the community or staff will be able to help you with this.
Seems strange. you are best asking the devs Submit a request – Facepunch Studios
UPDATE: I contacted Facepunch, one of their suggestions was, "We've also been recently made aware of a Citrix incompatibility with Unity. If you have any sort of Citrix communication software installed try uninstalling it." This was it. I had to install Citrix for a class, I uninstalled it, Rust is working now.
Sorry, you need to Log In to post a reply to this thread.