0.00 bug?

Hello, i have a rp server running cider. And when i write in the chat then it puts " “0.00 in the back of what i write. Example: Hello” "0.00

Help please! It ruins RP

Use notepad++, search for 0.00 and delete it. Problem solved.

Should i search in all my files?

Could someone please answer?

One of gmod’s string functions was changed to improve performance, but a side effect is that it returns a second value. Since most addons call that function as an argument to another function, you get strings with 0.00 at the end. This is not a simple “find 0.00 in your lua” job. All of those addons need to have their code changed to account for this second return value.

I removed the player_infocard.lua can that be why?

I think Garry has to fix it.

Problem is not solved before i say so.

For the 3rd thread, i have a fix that won’t require you fucking around with the gamemode, PM me.

I think people prefer to fix the gamemode by changing 1 line of code compared to whatever crappy fix you think you may have.