1/21/16 Error After Game Update: Disconnected EAC: EAC Disconnected Error

Update There has been an update pushed through via steam, this update does appear to have resolved the issue. Please Log-in to Steam and download.

Hello,

I’ve run into a bit of an issue after the recent update on 1/21/16. I was playing fine all day, then after the update I’ve been unable to play more than 2-5 minutes. I am able to launch the game fine, I’ll play for a couple minutes and then I will be disconnected receiving the following error message:

Disconnected EAC: EAC Disconnected

I assume this is related to the Easy Anti Cheat software, I have not made any changes to my game files and can assure you I have not made any attempt to cheat/hack/exploit in any way. As i’ve said, I was playing for a couple hours straight before this happened no changes made other than the pushed update. This error occurs on any server I attempt to connect to official and community alike. Below are the specs for my Mac to further assist in getting the issue resolved.

Mac Pro
Early 2009
Processor 2 x 2.26 GHz Quad-Core Intel Xeon
Memory 15 GB 1066 MHz DDR3 ECC
Graphics NVIDIA GeForce GT 120 512 MB
Software OS X 10.9.5 (13F1507)

I understand my graphics card is a little under powered however with the settings turned low it’s been working fine, I have already ordered a better one and I’m just waiting for it to arrive. This does not appear to be graphics related as the game will run just fine for 2-5 minutes without lag. The launcher itself works just fine, I simply get disconnected from what appears to be the anti-cheat software after about 2-5 minutes of normal gameplay regardless of activity or movement.

Edit:
Troubleshooting Steps Attempted

  • Tried multiple servers.
  • Closed and re-opened Rust
  • Closed and re-opened Steam
  • Launch directly from steam library
  • Verified Integrity of Game Cache
  • Uninstalled/Reinstalled Local Files
  • Ensured my computer was the only one accessing my steam account.

Any assistance you could offer would be greatly appreciated please and thank you.

Update Holmzy has stated this issue is something the Facepunch staff are aware of and are currently working to resolve. Please post your OS and version may assist them in resolution.

Update As of 1:02am EST This issue does not appear to have been resolved. I just tested it and was disconnected within 2 minutes. Just wanted to try and keep everyone updated with the current status as we have yet to hear any further information regarding this issue from the developers.

Update As of 3:21am EST This issue does not appear to have been resolved. I just tested it and was disconnected within 2 minutes. Just wanted to try and keep everyone updated with the current status as we have yet to hear any further information regarding this issue from the developers.

i have the same problem, on steam discussions aswel like 20 others have this problem on MAC and Linux.

Oh thank god so i’m not alone, this has been extremely frustrating, not quite familiar with the forum rules but are you allowed to post the link for me to the steam discussions?

im having the same problem to

Me and 3 friends on Mac OSX got the same issue. Check this reddit link: https://www.reddit.com/r/playrust/comments/421shb/official_bug_reporting_megathread_devblog_94/

Thank you very much LSERRE75, any information helps. Well wouldn’t be the first time we Mac users had to stare in the face of adversity lol. Stay strong my Mac brethren.

the developers need a backup update because i dont think anyone wants to wait another week for this fix

I am facing the same issue. I installed the game from scratch no success.

I’m sure they are aware and working on it given the response not only here but also on the steam community and reddit. I would really hope this wouldn’t take a week to correct. I understand this game is in alpha and I understand Mac users are a minority, I also understand that with any update there can be issues. So i’m really trying to be understanding about this.

We are aware and working on it

Thank you Holmzy I appreciate the update, knowing its known is met with a grateful sigh of relief.

thanks so much holmsy

Sorry for being annoying but how long will it take few minutes, hours days?

I can concur that this is an issue. I’m on Seattle II and have tried almost all the fixes possible to correct this issue, verifying files, reinstalling, etc. Nothing works. It’s very frustrating, because even though it wasn’t supposed to be wiped according to rust twitter accounts, it did, and rebuilding post-wipe is very important early on. All mac users are denied this. I understand there are always new bugs introduced post-updates, but if this could be prioritized, that would be beautiful. What is the eta for a fix like this, if it’s known what the issue is, that is?

Friduwulf given the quick response of users such as you an I, the number of users affected and understanding that this issue essentially prevents all gameplay i’m sure its being taken as a priority. Trust me I feel your pain I was kicked out as we were building our base on a fresh server and as soon as i left my team-mates started getting raided.

[editline]21st January 2016[/editline]

Any news? this is torturous! my base just got raided and all our stuff got stolen because i wasn’t there to help.

I feel… I got the update and the game wouldn’t launch because it had a problem with ciritification of the EAC. I verified game cache, restarted computer, restarted steam, reinstalled rust, reinstalled EAC. The only thing that’d launch the game was if I opened the game through my computers files. Even then, I I’d be disconnected immediately from a server for a EAC error. It saddens me because I just started playing again yesterday after not bring able to play for months ever since a past update prevented windows7/vista players from playing.

Good to hear that they are working on it. Just wanted to also add that I am running Ubuntu 14.04 LTS and I am also getting EAC Disconnects as well.

You aren’t being annoying. It’s no longer uncommon that these updates are crippling players.

I’m no tech dude so i don’t understand things like this but what could’ve caused this to happen

Well may be a stupid question but could the update be reverted until the underlying cause of the issue is found?

@cjkin290 were not sure yet no announcements other than they are aware. Some people on reddit said it could be server side with Easy Anti Cheat, one post said they disabled it on their server and it resolved the issue. Obviously not ideal and not verified but… possibility.