100% working fix for gmod crashes

Very simple fix thanks to someone on the byb forums.

Just type “vgui_allowhtml 0” in console, and all of your problems are solved.

Resource:http://www.bybservers.co.uk/gmod/index.php?topic=11025

Tested and 100% working

Worked! Thanks!

And damn you for beating me to it :stuck_out_tongue:

[editline]7th September 2012[/editline]

And also, you have to type it in everytime you start the game, or atleast until Garry releases a fix.

Neat!!!

Will try now…

Works as a marvel thank you very much. Saved my weekend :slight_smile:

If you don’t want to do it every time, add it to your command line options in Steam.

Oh man, thank you SO MUCH. I was tearing my hair out, because my game started doing this after I formatted the computer… So I kept assuming the problem was due to new drivers I installed, or something to do with how I set Windows up.

THANK YOU <3 <3 <3

Pretty sure you can just add it to the launch options.

You think if a server disabled HTML MOTD’s it’d work?

Worth a shot but probably not.

The loading screen is HTML

http://www.youtube.com/watch?v=B1511CexpMg check it out

sv_loadingurl " " will fix it for everyone, so they don’t have to run vgui_allowhtml.

Indeed it does, thank thee TheDivinity.

Also turn your motd things off etc. Anything that users html panels.

I wish Garry’s Mod had a autocfg by default. Would make this easier

Doesn’t work, I can’t set sv_loadingurl to null

Edit: Oh nvm, I looked at the default lol

Edit2: It works!

I could kiss you!

Unfortunately, this will disable Toybox as well. Though this isn’t a big deal considering that the game is functional. Just gotta wait for Garry to get back to fix it I suppose.

I uninstalled GMod For Nothing >_>

Anyone know if Garry put in a fix for this yet?