3D Ripper DX nor NinjaRipper do not work on Dead Space 3.

So I’ve been trying to run those two model extracting softwares on Dead Space 3 and neither works.

First, I tried 3D Ripper. It launches the game but the extra bar on the top left corner doesn’t appear nor does pressing the activation buttons anything.

Same thing with NinjaRipper. It opens the game but nothing indicates that it is turned on ingame. Pressing activation keys does nothing. I tried the injector as well as the dx11 wrapper but neither works. Haven’t tried the others though.

However, NinjaRipper gives these logs to the output folder:
0826/232047 [2A34] Ninja Ripper 1.5.1 x86
0826/232047 [2A34] © 2004-2015 black_ninja

0826/232047 [2A34] LOG START
0826/232047 [2A34] Inject mode: “intruder”

0826/232047 [2A34] Texture downscale max width : 4096
0826/232047 [2A34] Texture downscale max height: 4096
0826/232047 [2A34] Texture downscale value: 2

0826/232047 [2A34] LdrLoadDll hooked. Target: 0x77EBE660
0826/232047 [2A34] LdrUnloadDll hooked. Target: 0x77EA3790
0826/232047 [2A34] CreateProcessA hooked. Target: 0x75490750
0826/232047 [2A34] CreateProcessW hooked. Target: 0x7546B000
0826/232047 [2A34] CreateProcessAsUserW hooked. Target: 0x77492C20
0826/232047 [2A34] CreateProcessWithLogonW hooked. Target: 0x774A8090
0826/232047 [2A34] CreateProcessWithTokenW hooked. Target: 0x77480F90
0826/232050 [1314] CreateProcessW(“C:\Program Files (x86)\Origin\Origin.exe”) return: 1
0826/232050 [1314] Injecting to child process. Status: OK

and

0826/232050 [2EC8] Ninja Ripper 1.5.1 x86
0826/232050 [2EC8] © 2004-2015 black_ninja

0826/232050 [2EC8] LOG START
0826/232050 [2EC8] Inject mode: “intruder”

0826/232050 [2EC8] Texture downscale max width : 4096
0826/232050 [2EC8] Texture downscale max height: 4096
0826/232050 [2EC8] Texture downscale value: 2

0826/232050 [2EC8] LdrLoadDll hooked. Target: 0x77EBE660
0826/232050 [2EC8] LdrUnloadDll hooked. Target: 0x77EA3790
0826/232050 [2EC8] CreateProcessA hooked. Target: 0x75490750
0826/232050 [2EC8] CreateProcessW hooked. Target: 0x7546B000
0826/232050 [2EC8] CreateProcessAsUserW hooked. Target: 0x77492C20
0826/232050 [2EC8] CreateProcessWithLogonW hooked. Target: 0x774A8090
0826/232050 [2EC8] CreateProcessWithTokenW hooked. Target: 0x77480F90
0826/232050 [2EC8] Loaded Modules List
0826/232050 [2EC8] --------------------------------
0826/232050 [2EC8] BaseAddr Size Module
0826/232050 [2EC8] --------------------------------
0826/232050 [2EC8] 0x01240000 (0x0037E000) C:\Program Files (x86)\Origin\Origin.exe
0826/232050 [2EC8] 0x77E70000 (0x0017B000) C:\Windows\SYSTEM32
tdll.dll
0826/232050 [2EC8] 0x75450000 (0x000E0000) C:\Windows\SYSTEM32\KERNEL32.DLL
0826/232050 [2EC8] 0x77650000 (0x0017E000) C:\Windows\SYSTEM32\KERNELBASE.dll
0826/232050 [2EC8] 0x70810000 (0x00092000) C:\Windows\system32\apphelp.dll
0826/232050 [2EC8] 0x772D0000 (0x0014F000) C:\Windows\SYSTEM32\GDI32.dll
0826/232050 [2EC8] 0x74BF0000 (0x00147000) C:\Windows\SYSTEM32\USER32.dll
0826/232050 [2EC8] 0x77470000 (0x0007B000) C:\Windows\SYSTEM32\ADVAPI32.dll
0826/232050 [2EC8] 0x771E0000 (0x000BE000) C:\Windows\SYSTEM32\msvcrt.dll
0826/232050 [2EC8] 0x76930000 (0x00044000) C:\Windows\SYSTEM32\sechost.dll
0826/232050 [2EC8] 0x76F10000 (0x000AD000) C:\Windows\SYSTEM32\RPCRT4.dll
0826/232050 [2EC8] 0x74BA0000 (0x0001E000) C:\Windows\SYSTEM32\SspiCli.dll
0826/232050 [2EC8] 0x74B90000 (0x0000A000) C:\Windows\SYSTEM32\CRYPTBASE.dll
0826/232050 [2EC8] 0x76C30000 (0x00058000) C:\Windows\SYSTEM32\bcryptPrimitives.dll
0826/232050 [2EC8] 0x76B40000 (0x000EB000) C:\Windows\SYSTEM32\ole32.dll
0826/232050 [2EC8] 0x77020000 (0x001BD000) C:\Windows\SYSTEM32\combase.dll
0826/232050 [2EC8] 0x75530000 (0x013FE000) C:\Windows\SYSTEM32\SHELL32.dll
0826/232050 [2EC8] 0x76C90000 (0x00037000) C:\Windows\SYSTEM32\cfgmgr32.dll
0826/232050 [2EC8] 0x73D30000 (0x0009B000) C:\Windows\SYSTEM32\WINHTTP.dll
0826/232050 [2EC8] 0x74B80000 (0x00008000) C:\Windows\SYSTEM32\VERSION.dll
0826/232050 [2EC8] 0x74E60000 (0x004FA000) C:\Windows\SYSTEM32\windows.storage.dll
0826/232050 [2EC8] 0x77420000 (0x00045000) C:\Windows\SYSTEM32\shlwapi.dll
0826/232050 [2EC8] 0x5DFD0000 (0x00071000) C:\Windows\SYSTEM32\MSVCP120.dll
0826/232050 [2EC8] 0x76E70000 (0x0000C000) C:\Windows\SYSTEM32\kernel.appcore.dll
0826/232050 [2EC8] 0x753C0000 (0x0008D000) C:\Windows\SYSTEM32\shcore.dll
0826/232050 [2EC8] 0x76AF0000 (0x00044000) C:\Windows\SYSTEM32\powrprof.dll
0826/232050 [2EC8] 0x772A0000 (0x0000F000) C:\Windows\SYSTEM32\profapi.dll
0826/232050 [2EC8] 0x77BF0000 (0x00092000) C:\Windows\SYSTEM32\OLEAUT32.dll
0826/232050 [2EC8] 0x5E050000 (0x000EE000) C:\Windows\SYSTEM32\MSVCR120.dll
0826/232050 [2EC8] 0x77CA0000 (0x00042000) C:\Windows\SYSTEM32\WINTRUST.dll
0826/232050 [2EC8] 0x77C90000 (0x0000E000) C:\Windows\SYSTEM32\MSASN1.dll
0826/232050 [2EC8] 0x77CF0000 (0x00179000) C:\Windows\SYSTEM32\CRYPT32.dll
0826/232050 [2EC8] 0x74400000 (0x0020F000) C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.10586.494_none_ea85e725b9ba5a4b\COMCTL32.dll
0826/232050 [2EC8] 0x76E40000 (0x0002B000) C:\Windows\SYSTEM32\IMM32.DLL
0826/232050 [2EC8] 0x63250000 (0x000C1000) C:\Users\Jarkko\Downloads\NinjaRipper\x86\intruder.dll
0826/232050 [2EC8] 0x747B0000 (0x00028000) C:\Windows\SYSTEM32
tmarta.dll
0826/232050 [2EC8] 0x6E1D0000 (0x00075000) C:\Windows\system32\uxtheme.dll
0826/232050 [2EC8] 0x10000000 (0x0005E000) C:\Program Files (x86)\RivaTuner Statistics Server\RTSSHooks.dll
0826/232050 [2EC8] 0x74A60000 (0x00024000) C:\Windows\SYSTEM32\WINMM.dll
0826/232050 [2EC8] 0x6E120000 (0x000A3000) C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.9177_none_5093cc7abcb795e9\MSVCR90.dll
0826/232050 [2EC8] 0x74A30000 (0x00023000) C:\Windows\SYSTEM32\winmmbase.dll
0826/232050 [2EC8] 0x76E80000 (0x00084000) C:\Windows\SYSTEM32\clbcatq.dll
0826/232050 [2EC8] 0x748D0000 (0x0001B000) C:\Windows\System32\bcrypt.dll
0826/232050 [2EC8] 0x6DA80000 (0x0001D000) C:\Windows\system32\dwmapi.dll
0826/232050 [2EC8] 0x77BE0000 (0x00006000) C:\Windows\SYSTEM32\psapi.dll
0826/232050 [2EC8] LOG END

I’m making a Dead Space mod for Left 4 Dead 2 so I need models for the mod. :slight_smile:

I can’t find the links right now, but I was able to use tools for Dead Space 2 on Dead Space 3 to extract the assets directly from the arches, then import the meshes and textures into 3DS Max 2012 64-bit. I should be able to provide a download link for the tools soon.

https://www.facepunch.com/showthread.php?t=1190028

If they’re Ninjaripper and 3D ripper DX, they won’t work on Dead Space 3, at least not for me. If you’re talking about the tutorial Cylonproject just linked me, I already know it and it doesn’t work for me. I have 3D Max 2016

[editline]29th August 2016[/editline]

I already said that 3D Ripper nor Ninjaripper do not work on Dead Space 3

It’s called Rick’s Tools, it can decompress the archives, no ripping involved. If you install the tool from this link, then use the Gibbed.Visceral.StrUnpack.exe program to unpack the archives, you can try installing theimporter script originally made for 3DS Max 2012 and hope that it works on your 2016 version.

I already got everything setup, everything. It’s just that 3D Ripper DX nor Ninjaripper do not work on Dead Space 3 and also the extra tools to open up the “scenes” created on 3D Max do not work on 2016 version of 3D Max. I’m not a great fan of getting the old 2011 version of 3D Max.