3D skybox doesn't render unless fullbright?

http://filesmelt.com/dl/radiostation0009.jpg

http://filesmelt.com/dl/radiostation0010.jpg

As you can see, when fullbright is on my skybox renders but when it’s off it doesn’t? I have no idea why this is happening. Compiled on Normal VRAD + Fast VVIS.

Try compilling with Normal VRAD + Normal VVIS
Sometimes doing it fast causes the compiler to screw things up.
Also, is the skybox texture a custom one? It looks like it has some sort of gap in it, causing me to believe that some settings in the vtf itself is missing.

normal vvis will take hours since I haven’t optimized the visleafs yet >__>

yeah it’s a custom skybox, although I can’t imagine what settings i’d need to change

Have you tried changing the texture of the skybox to see if the custom one is the culprit?

Is there a light_environment in the 3D skybox? I highly doubt this is the problem, for many reasons, but give it a shot.

light_environment can be placed anywhere (inside the map not in void). Only 1 can be placed any others will be ignored by the compiler.

My guess is your vmt is slightly out or missing a line. Paste your vmt and we shall see.

Compiled both on full, no change. What VMT’s do you want?