3D2D not showing up?

Im not sure what im doing wrong, but I have looked from every angle to see what I have drawn and its still not showing:



hook.Add("HUDPaint", "uni", function()

cam.Start3D2D( Vector(-704, 0, -12223), Angle(0,0,0), 4.25 )
		draw.DrawText( "DUOR,asdfijaosdijfoaisdjfoasjdfoijsodafjoasdijfoijsdoiafjsodifjoasidjfoasidjfoiadjsfoijadsoifjoasdij DUR", "HUDNumber4", 2, 2, Color( 255, 255, 255, 255 ))
		draw.SimpleText("test", "HUDNumber4", 0, 0, Color(255,255,255,255))
	cam.End3D2D()
end)



The hook is working as I have tried printing from within it and it works fine. Its supposed to show up at the spawn of GM_Flatgrass…

Try



hook.Add("PostDrawOpaqueRenderables", "uni", function()
	cam.Start3D2D( Vector(-704, 0, -12223), Angle(0,0,0), 4.25 )
		draw.DrawText( "DUOR,asdfijaosdijfoaisdjfoasjdfoijsodafjoasdijfoijsdoiafjsodifjoasidjfoasidjfoiadjsfoijadsoifjoasdij DUR", "HUDNumber4", 2, 2, Color( 255, 255, 255, 255 ))
		draw.SimpleText("test", "HUDNumber4", 0, 0, Color(255,255,255,255))
	cam.End3D2D()
end)


You must first start a 3D camera. ( cam.Start3D )

What? No you don’t.

AHa! It complained about HUDNumber4 being an invalid font so I put it to default (all in lower case) still to no avail.

Yes you do in 2D drawing hooks like HUDPaint.

Tried your method, Robot and it yielded the same results

You did it fucking wrong.


hook.Add("HUDPaint", "uni", function()
	cam.Start3D( EyePos(), EyeAngles() )
	cam.Start3D2D( Vector(0, 0, 0), Angle(0,0,0), 4.25 )
		draw.DrawText( "DUOR,asdfijaosdijfoaisdjfoasjdfoijsodafjoasdijfoijsdoiafjsodifjoasidjfoasidjfoiadjsfoijadsoifjoasdij DUR", "Default", 2, 2, Color( 255, 255, 255, 255 ))
		draw.SimpleText("test", "Default", 0, 0, Color(255,255,255,255))
	cam.End3D2D()
	cam.End3D()
end)

Shows the thing on gm_construct just above the spawn. It will be drawn over everything else, since you draw it on HUDPaint, so you should be using PostDrawOpaqueRenderables WITHOUT the cam.Start3D.

Oh, thought you replied to Sudoxe who used “PostDrawOpaqueRenderables”.