3DS Max - .obj mesh distortion

Hello. So I got this rather serious problem with 3DS Max at the moment, and I have no idea how to fix it. Simply put, I got a .obj file which I need to import to 3DS Max for use with Wall Worm, but trying to import the .obj file into 3DS Max (2015) will result in the mesh looking all distorted.

The .obj file works just fine if trying to import it to Blender. I have tried importing other .obj files into 3DS Max just to see if it happens with all .obj files, but they work just fine.
A couple of adjustments have been made to the .obj file such as removing unwanted faces, scaling everything, etc. I have already normalized the position, rotation and scale in Blender.

Here are some screenshot comparisons:

Blender

http://i.imgur.com/qzUT0D2.png[/t]

3DS Max
[t]http://i.imgur.com/15hIEO4.png[/t]

This is what the import options are set to:
[t]http://i.imgur.com/mXGbFcW.png

Help is appreciated.

Try deselecting “Retriangulate Polygons” in the top left corner.

If that does not work, import the file into Blender, and either export it back out as OBJ or export it as any other available format that you can import into 3DS Max.

I tried deselecting “Retriangulate Polygons” but that doesn’t fix it sadly. However, I noticed that selecting “Import as single mesh” works, but I’d rather not do that since I am planning to export the entire object into a Valve Hammer .vmf map, and having everything as one mesh will probably mess things up.

I tried exporting it as a .3ds file in Blender, but then it just tells me it’s a “Improper file format”. I tried exporting it as a .dae file as well, and that works but I couldn’t get the textures to load on the model.

You need to manually replace every instance of “o modelnamehere” with “g modelnamehere” in the obj to get the obj to work in 3ds max. For some reason the obj exporter in Blender uses different syntax for the same thing.

Thanks a lot for the advice, I tried it now and it worked.