3Dsmax 9 mdl plugin?

I just bought 3dsmax 9 and Realize it doesn’t open .mdl files nor does it save to .mdl. Is there a plugin to do this or another program?

Please help :smiley:

No but you can import and export .smd’s

…which you get by decompiling MDLs…

You can get the mdl decompiler here: http://chaosincarnate.net/cannonfodder/cftools.htm

And you can get The .SMD importer here:http://www.wunderboy.org/sourceapps.php#max9_smd

Thanks, I downloaded both, But the mdl decompiler doesn’t work. When I click it and try to launch it, it says “This application has failed to start because vstblib.dll was not found. Try re-installing the application may fix this problem.”

Lol I have no clue where to get it, It didn’t even come with it. The package only contained a read me and the exe.

Oh wait, It told me to put it in the sdk bin folder in source sdk, but it still doesn’t work, it says “the procedure entry point Q_Appendslash could not be located in the dynamic link library vstblib.dll.”

You mean smd EXPORTER, not importer? Got my hopes up there for a second.

Same thing i think. I’m lead to believe the mdl decompliler decompiles it to smd and in 3dsmax 9 you use the exporter to export it or something i dunno.

Importer = Loads an smd file
Exporter = Saves an smd file

I’m not sure if the importer works for i do not import often but if it does not try this one: http://pages.videotron.com/browser/Downloads/3d_max/scripts/SMDImporter1-0.zip

How do i get the mdl decompiler to work?
Can someone at least try it so they can tell me how to get it to work? I put it in the bin folder of source sdk but it still gets the error i posted above.

Edit: I put it in my hl2 bin folder now and it runs, but when i try decompiling it, it says “Extra app id” error thing.

All I want to do is model :S

The decompiler does work, I have used it before.

Try this decompiler: http://www.kathar.net/other/mdldecompiler.exe

Make sure you put it in either the “…\sourcesdk\bin\ep1\bin” (or) “…\sourcesdk\bin\orangebox\bin” folder.

It starts up in the episode 1, but I get the extra app error thing in it. In the orange box i get the q_appendslash error.

I am having trouble decompiling orange box models too

I was having the same issue. I put the file on the source sdk base folder instead. Now it works.

I’m pretty sure you still have to hack the individual .mdl files so they’re compatible with the old version.

Yes you still do have to edit the files (not hack) in notepad +.

I get this error when I try to decompile .mdl’s.

http://www.filecram.com/files/problem1.jpg

Uncheck the use steam file access.

do i have to put the decompiler in my hl2 folder???