(-500) Client error (Error writing request: The authentication or decryption has failed.) Gmod

what am I doing here we have centos and we have installet
libstdc + +. so.6: and GLIBCXX_3.4.1

ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Initializing Steam libraries for secure Internet server
SteamGameServer_InitSafe failed!
************************************************** *******
************************************************** *******
* Unable to load Steam support library.*
* Unable to load Steam support library.*
* This server will operate in LAN mode only.*
* This server will operate in LAN mode only.*
************************************************** *******
************************************************** *******
failed to dlopen /home/tcagame/admin/9/garrysmod/bin/lua_shared_srv.so error=/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by bin/libsteam.so)
Couldn't locate library [lua_shared_srv] or couldn't find module [LUASHARED003]
Couldn't Load Library 'lua_shared_srv' (looking for interface LUASHARED003)Couldn't Load Library 'lua_shared_srv' (looking for interface LUASHARED003)

Regards HrP0st

It’s saying GLIBCXX_3.4.14 isn’t found are you sure you installed that exact version?

Is your machine running 32- or 64-bit OS?

If 32-bit, make sure you yum these packages:


yum install glibc.i686 libstdc++.i686

Since you use TCAdmin, are you sure the user that launches the server have rwx permissions to the server files?