8 Gigs of ram not enough?

When i play rust my usage start to go high as 90%
so that means if i wanna browse or anything on my second monitor i will crash due to ram usage, i have 8 gigs in my system which i thought would be enough, but apparently not?
so i wanna know if this is normal behavior from the game.

For me, it is. And well, 8 Gigs are enough. You simply can’t do much in the background. Try to play on a server with small map size. Also, the game shouldn’t crash if you’ve got your swap file activated. :slight_smile:

i’m also using 8GB ram and i don’t really have a problem. i can alt tab into different stuff like youtube and netflix while rust is running in the background.

dont forget if your ram is fully utilised, your system will “Page File” which basically borrows virtual RAM space from your hard drive… so long as you have it set up to do so. usually, there is a default page file setting, so it shouldnt crash on you.

I actually disabled the pagefile yday, that might be the reason for this happening?

This is the reason. You should at least set it to 2048MB.

Seems your RAM is not fully compatible with your processor that is way too much usage.

actually it was not disabled, but the settings been picked as recommended by my ssd, aint these correct?

youre ram usage is enough if you only play rust. But the ram usage will prohably change in the future since its still in development.

Dont think that’s the issue, i’ve had these rams & cpu for the past 2 years.

Could be a caching issue issue.

Which means?

Has never been enough for me, try disabling hardware accelerating if it’s using too much.

As I said, enter at least a fixed value of 2048MB (in both fields), better more like 4096MB, if you’ve got enough hdd space. This should (!) help. If not, close as much background tasks as possible and look for a browser that’s maybe not as much ram consuming as chrome is (even though it’s my favorite one). :slight_smile:

Like poppadomus said, to me it looks like your ram is having some sort of issue, 5.3gb out 8gb is not even close to 93%, it’s actually more like 65%. So unless system tasks and background tasks are using just over 2.1gb ram (which they could well be, but this seems a bit high to me.) I would think you have a ram issue of some sort.

But that’s just a thought, might not actually be what’s going on. I’d start by closing any background tasks that are unneeded or are hogging up a lot of ram.

I had this exact issue a while ago and it was due to setting my pagefile to low and im guessing you have a samsung SSD due to the settings you used.

I have a samsung SSD and it does recommend setting the pagefile to 200 min and 2048 max but i do not advise this and personally i would set the max to 16 gig / 16,384MB.

8GB of RAM is the minimum system requirement for Rust, btw, not the recommended specs. The game’s in alpha so expect things to go wrong.

If you disable your pagefile and then run your system out of RAM, it can’t do anything but crash if you try and make it use more memory than it physically has. That’s specifically why the pagefile exists.

Typically, the pagefile is double the RAM size; that pagefile is 25% of the RAM size. Make the pagefile max be at least 8192MB, equal to your RAM size. If you have an SSD and an HDD in your machine, I’d do this:

  • DISABLE the pagefile from being on the SSD
  • ENABLE the pagefile with an 8GB-16GB max on the HDD
  • Reboot to apply settings

‘8GB of RAM is the minimum’:what: I’ve been playing with 3gb for like 2 months, to be honest, its not that bad, just lagspikes that happen rarely.

Right there on the Steam Store.

You’re lucky to get away with it.

I’m guessing on medium to low settings though. On max setting my computer uses no less then 3.9gb. So you’re either very lucky, or are playing on potato settings.

you using Windows 10 and need required 16gb ram.

Please buy 8gb only 40$, get total 16gb ram and enjoy.