A fix for the new gmod water lag.

I had really bad water lag after the update in gm_construct, like a lot of others did. Then i remebered that GiGaBiTe said something about water calling for a 7.vtf or a 8.vtf or a 6.vtf that isn’t real 1000 times every second, which is causing the lag. So, i made the 7, 8, and 6 vmt files, popped them in materials and, wow, no lag. My FPS was back up to 90.

Anyways, here are the files to fix the lag.
http://www.garrysmod.org/downloads/?a=view&id=29228

Credits to GiGaBiTe (Or was it someone else?) for finding this out.

Put this in your c:\Program Files\Steam\Steamapps\username\garrysmod\garrysmod folder.

Note: This just fixes the lag, not the white water or checkerboard water.

Thanks, very useful.

Anyone tried this?

You might want to fix the description of your download, otherwise it may not be very appealing to users who did not see this thread beforehand.

That fix only helps the problem to make it bearable, it doesn’t fix it. The problem is with wiremod and spamming the filesystem trying to load a file called 8.vmt (among other random files) which kills the engine. If you use the Microsoft kernel debugger, you can see what files it’s spamming reads from.

This is useful for anyone who’s lagging like hell when staring the water

For some reason, this crashes my GMod…

… or not. I guess it was just a coincidence.

Thank you so much! This fixed up the issue I was having.

Fixed me up as well. Was getting 25 fps looking at the “pond” Now I get my 50 again!

Thank you very much, I haven’t been getting any of the other problems that many others are reporting, but even if I stare at a wall that has water behind it my fps goes to shit.
So other than my categories being arranged in an annoying way everything is perfect now. Thanks again!

Thank you!


"Water"
{
	"$abovewater" 1
	"%compilewater" 1
**	"$forceexpensive" 0**
	"$reflectentities" 0
	"$envmap" "env_cubemap"
	"%tooltexture" "nature/water_frame01_normal"
	"$refracttexture" "_rt_WaterRefraction"
	"$refractamount" "1"


	"$reflecttexture" "_rt_WaterReflection"
	"$reflectamount" "0.4"

	"$scale" "[1 1]"

	"$bumpmap" "nature/water_coast01_dudv"
	"$normalmap" "nature/water_coast01_normal"

	"$surfaceprop" "water"
	"$bottommaterial" "gm_construct/water_beneath"
	"$bumpframe" "0"

	"$fogenable" 1
	"$fogcolor" "{7 66 58}"
	"$fogstart" -512.00
	"$fogend" 2096.00

	"$scroll1" "[.01 .01123 .05]"
	"$scroll2" "[-.015 .015 .01512]"

	"Proxies"
	{
		"TextureScroll"
		{
			"texturescrollvar" "$bumptransform"
			"texturescrollrate" .02
			"texturescrollangle" 25.00
		}
**		"WaterLOD"
		{
			"$cheapwaterstartdistance" 400
			"$cheapwaterenddistance" 900

		}**
			
	}
}


Would this help?

Thanks! Was getting 10 FPS while looking at the pond, and now I get 30.

Gigabyte: I have just had a look into if the case was indeed a problem with wiremod, but after removing it entirely from my system i still found that gmod was still calling 8.vmt.

Placing 8.vmt back into the materials folder however then solved the issue for the time being.

There must be some reason why Gmod is calling 8.vmt.

Confirmed, it’s not due to wiremod.

Also, it appears that different types of water call different vmt’s… The fix is valid for construct (and most TF2 maps somehow), but not for, say, rp_omgcity (though that might be an entirely other problem somehow).

Coupled with fact that certain water types (gm_winterconstruct) don’t seem to have in-water refraction materials/instructions/whatever, that’s probably what it’s calling.

this fix ? is it a fix for people with white water too?

Thanks it Fixed the lagg and made it so it wasn’t white from above but i still see the purple squares when in the water

so it will fix the white water from above? i don’t play in the water anyway :stuck_out_tongue:

Also might want to add some search tags to the download so people can find it without going here.

Added tags, glad this is working for everyone, but remember to give most the credit to GiGaBiTe.