A spot of trouble compiling tf2's soldier's shovel model-swap.

Hi, apologies if this is the wrong forum, I’m new here and I’m not sure just how it all works just yet.
I’m in need of a little assistance, I ran a search for “compile error tf2 shovel” and came up with nothing that can help me. I started modeling about a week ago, but rather than start with my own model I tried to do a simple model swap to see if I could do it if I ever got that far. I used an axe model (for my own personal use, not release, I don’t think I need permission for that) and got the uv map to work and everything.
My trouble arises from assigning bones to the axe. The soldier’s shovel has to parts to it, the weapon_bone and the shovel_head. When assigning bones to the axe model, I’m only able to assign to the shaft of the original shovel or the shovel head, not both. Example:

http://img41.imageshack.us/img41/6315/wip1t.th.jpg

http://img41.imageshack.us/img41/9316/wip2v.th.jpg

And here is where I have trouble: Even if I click assign after selecting the axe group, I can only assign the axe to the handle or the shovel head bones, not both, even when I tried.

http://img43.imageshack.us/img43/7833/wip3l.th.jpg

http://img41.imageshack.us/img41/2789/wip4r.th.jpg

And when I tried to only assign the axe model to the weapon_bone, compiling it gave me this error:

http://img31.imageshack.us/img31/3752/error1q.th.png

Any help at all would be appreciated, once again, apologies if I’m in the wrong forum.