(Abandonware) Zompocalypse / The Last Stand 2 - If you can fix it, you can have it

I’m not going to type up a big long post about this, because I couldn’t care any more.

Here’s my gamemode, Zompocalypse (based off the flash game, The Last Stand 2). It’s about 99.8% complete, minus the map, which has more rooms to be added.

Uses InfiniDungeon system.

Basic premise of the game is to survive and reach Freedom City within 40 days. Game is split into three phases: Barricade, Defend, and Recuperate/Travel. During Recuperate phase, players spend points into healing, searching, or barricading. Supplies are used to travel to new locations. As the game progresses, waves get harder - distance to the city controls zombie numbers, days into the game control zombie strength.

Have some media.

Problems: Only problems revolve around traveling. Sometimes players don’t get teleported to the forest. Sometimes they get stuck infinitely in the forest. Sometimes the barricade phase starts in the forest. Sometimes they go backwards in the forest. And sometimes people go into different render cells, so they can’t see everyone else, if they don’t go to entirely different rooms.

**


If you can fix it, you can have it.

** I don’t care if you take full credit for the gamemode, you can have it. I spent the last 5 days trying to fix these problems, and I just don’t care any more.

Fun fact: Today is my birthday, and in a token of reverse tradition, you can consider this my birthday present to you all.

DOWNLOAD FULL GAMEMODE
InfiniDungeon Entities (Fixes the errors preventing gameplay and such)
(Apparently) Different InfiniDungeon Entities (If the above ones don’t fix it, try these.)

Map VMF

I only hope someone picks it up and finishes it, or does something with it. I’d hate to see nearly a month of my life just disappear like this. Fact of the matter is, though, that I can’t do this any more. This game has frustrated me to the point where just looking at it sit in my gamemodes folder makes me want to punt puppies. I have other things to do, and I won’t let this game consume my life any longer.

As soon as I hit “Submit New Thread,” I am actually going to start work on my new gamemode.

Thanks all for reading, and have a great summer/winter (depending where you are). :buddy:

cool thanks if I fix Im gonna host it.

If a good coder can actually manage to create a fix, PM me. I want to map for this.

Happy Birthday

Freedom city?
Isnt that the city in hellmoo?

Cool, its my birthday to :downs:

Can’t wait to see a server host this when it gets fixed.

This looks like an interesting gamemode.
If you want it fixed up and hosted pm me.

I might try my hand at fixing it… Or I would if I didn’t have so many other things to do…

Don’t need permission or anything.

As of the moment I hit “Submit Thread” this game is completely abandoned. If I wasn’t a compulsive pack rat, I’d have deleted it off my hard-drive, too. If you want to fuck with it, go ahead.

The fact I comment everything heavily should make it so you understand pretty much everything I do. :v:

Its pretty much full of 1000000 errors, but meh. might fix this sometime, i just instantly get the “you lost” thing. Should be fixable

That’s curious.

Never had that happen before. :v:

Like I said, the only real errors all revolve around traveling in that god-damn forest. See the video - it works fine except for that. Not sure what causes those errors for you, other than you tend to be a magnet for causing everything to break. (:v:)

No there is definatly something wrong during the first phase (never actually got to second), the “barricade menu” is totally bugged out and then a sudden you lost… too bad you’ve deleted the build on your computer, cause i think you might got some of the files damaged/lost in the uploaded build =(

I’ll download the uploaded version, see what’s wrong…

I know abandonware means I don’t support it at all, but it should work fine… :geno:

[editline]03:50PM[/editline]

No clue what the fuck you guys are talking about. It works fine for me.

Downloaded it, renamed the gamemode folder, dropped it into my gamemodes folder, fired it up. Just played the first five days no problem before deciding to call it good.

You guys are playing the map, right? zompoc_countryside_v4d?

Because, if you’re not… :downs:

Then what?! ;b

It looks really great, apart from the bug.

I’ll try re-downloading it, again =)

[editline]05:25PM[/editline]

Just tried again, even with another computer but still get the same errors =(
Im not the most experienced lua coder, but i’ll give a shot =)

I am getting the same errors too, i would really like to try this.

Any actual Lua errors (ie the blue/orange errors that spam your screen), or just the game fucking up?

Looks like its same shit like it was on infinidungeron, could you please upload the addons you have on the server thats related?

[editline]07:54PM[/editline]

ERROR: GAMEMODE:‘PlayerSpawn’ Failed: gamemodes\zompoc\gamemode\init.lua:431: attempt to get length of field ‘inside’ (a nil value)

gamemodes\zompoc\gamemode\shared.lua:220: attempt to index field ‘?’ (a nil value)

to name a few

[editline]07:59PM[/editline]

what the shit, now i spawned somewhere totally else

[editline]08:00PM[/editline]

Its pretty much assuming that stuff that dosent exist there would magically apprear…

Actual lua errors

Here’s a list of all my addons:

I don’t know what’s causing those errors. The first error you provided is regarding themes, which should be working fine.

The second one is the end of this function: [lua]function Barricade_GetCost(mdl)
return math.Round((STORED_MODELS[mdl].Size * BARRICADE_COST_MULTIPLIER_SIZE) * (STORED_MODELS[mdl].Mass * BARRICADE_COST_MULTIPLIER_MASS))
end[/lua]

I honestly don’t know what’s going on. It works perfectly fine for me (see video), and I was able to download and install what I uploaded without any problems. :geno:

Regarding the spawning in different places: That’s intentional.