AddCSLuaFile not working?

I searched the forums but this is such a simple problem I wasn’t able to really pull up any answers



resource.AddFile( "cl_init.lua" )--if all else fails...
resource.AddFile( "shared.lua" )--if all else fails...
AddCSLuaFile( "cl_init.lua" )
AddCSLuaFile( "shared.lua" )

include( "shared.lua" )


Thats the very top of init.lua
I’ve removed the rest of the content from the scripts to test just these functions

clients get this:

This is nearly a **fresh **install of GMOD with no other mods installed, just a few helper files that I wrote.

I am also hosting the game as a **listen **server, not dedicated.

I feel like this is incredibly basic and I’m just missing a simple detail.

UPDATE:

I uninstalled gmod, deleted all cache files and reinstalled.
I ran a test with one client and it worked!
Later when I had more people to test it ended up only working for one client… I have no idea why XD

Yes, remove lines 1 and 2

Okay, I’ll try! Why should that work?

UPDATE:
Didnt work :frowning:
Any other advice?

Remove line 1 & 2. Line 3 and 4 are fine by themselves.

Why is that? Reading over other scripts I see these two coupled together. Is it unnecessary to have both? I’m confused.

Well, either you’ve misspelled cl_init.lua (in the filename) or you are trying to include a file in the wrong directory. Double-check that the file you’re trying to include is in the same directory as the file you are writing the code in. If that’s not the case, you have to adjust your path.

Thats my file structure. Its very very basic.

This actualy is not fixed. Anyone have any suggestions?