Adding soundscripts to NPC addon

Hey, I’ve got an NPC with a soundscript (txt file) that I want to upload to the workshop. However, the soundscript needs to go in garrysmod/sourceengine/scripts. Gmad won’t let me add a file there, and as far as I’ve tried, it won’t let me upload soundscripts at all. I’ve already got the model, animations, npc class etc. working, all I need is the sound. So how do I do that?

I decided to try adding the soundscript to my npc’s autorun.lua. I had to edit it a bit, and for example


 "Zombine.Charge"
{
	"channel"		"CHAN_VOICE"
	"volume"		"0.9"
	"pitch"			"90, 110"

	"soundlevel"	"SNDLVL_NORM"

	"rndwave"
	{
		"wave"	"npc/zombine/zombine_charge1.wav"
		// "wave"	"npc/zombine/zombine_charge2.wav"
		"wave"	"npc/zombine/zombine_alert6.wav"	
	}
}

Became



sound.Add 
{
	name = "Zombine.Charge",
	channel = CHAN_VOICE,
	volume = 0.9,
	pitch = {90, 110},
	level = SNDLVL_NORM,
	sound = {"npc/zombine/zombine_charge1.wav", "npc/zombine/zombine_alert6.wav"}
}


Which for some reason beyond my knowledge seems to work. It works for all the other sound files aswell… Except the walking sound. Here’s the original soundscript entry



// play scuffright/scuffleft when zombine charges

"Zombine.ScuffRight"
{
	"channel"		"CHAN_BODY"
	"volume"		"0.95"
	"pitch"			"PITCH_NORM"

	"soundlevel"	"SNDLVL_65db"

	"rndwave"
	{
		"wave"	"npc/zombine/gear1.wav"
		"wave"	"npc/zombine/gear2.wav"
	}
}

"Zombine.ScuffLeft"
{
	"channel"		"CHAN_BODY"
	"volume"		"0.95"
	"pitch"			"PITCH_NORM"

	"soundlevel"	"SNDLVL_65db"

	"rndwave"
	{

		"wave"	"npc/zombie/foot_slide1.wav"
		"wave"	"npc/zombine/gear3.wav"
	}
}


And here’s my entry (in the autorun.lua)



-- play scuffright/scuffleft when zombine charges
sound.Add 
{
	name = "Zombine.ScuffRight",
	channel = CHAN_BODY,
	volume = 0.95,
	pitch = PITCH_NORM,
	level = SNDLVL_65db,
	sound = {"npc/zombine/gear1.wav", "npc/zombine/gear2.wav"}
}

sound.Add 
{
	name = "Zombine.ScuffLeft",
	channel = CHAN_BODY,
	volume = 0.95,
	pitch = PITCH_NORM,
	level = SNDLVL_65db,
	sound = {"npc/zombine/gear1.wav", "npc/zombine/gear3.wav"}
}


Whenever I enter an invalid path, I get no errors, while I do get them with other sounds when I change the path (like the zombine dying, or grabbing a grenade) so I suspect the problem is that the sound isn’t getting called due to being given the wrong name. That doesn’t explain why it does work when I put the soundscript in garrysmod/sourceengine/scripts, though. I’ve also tried several other names (walkLeft, WalkLeft, move, Move, moveLeft, Moveleft, footstepLeft, FootstepLeft) but none of them work. Ideas? Or should I try a different approach altogether.

Couldn’t find rules on bumping (or rules at all) so I hope it’s okay as I’ve waited 24 hours.

Bump