AddNotify not working? DarkRP.

Hi, the AddNotify command isn’t working on my money printers, and I need to know why and/or how to fix it! Thanks!


 GAMEMODE:addNotify(activator, 1, 4, "You have collected $"..self:GetNWInt("PrintA").." from a Money Printer.") 

here’s one of the few, they are all set up this way, the error is saying AddNotify is a nil value. I also tried addNotify, addnotify, Notify and notify. Thanks!

AddNotify, capital A

Already tried that, doesn’t work. :confused:

Try rewriting the entire function. Like this:
[lua]//TRANSLATIONS
//If this conflicts with something then trying changing the variables ex: GENERIC = ‘NOTIFY_GENERIC’ etc
NOTIFY_GENERIC = ‘NOTIFY_GENERIC’
NOTIFY_ERROR = ‘NOTIFY_ERROR’
NOTIFY_UNDO = ‘NOTIFY_UNDO’
NOTIFY_HINT = ‘NOTIFY_HINT’
NOTIFY_CLEANUP = ‘NOTIFY_CLEANUP’

local sadf = FindMetaTable(“Player”)
function sadf:AddNotify(text, type, length)
self:SendLua(“notification.AddLegacy(’” … text …"’, " … type … ", " … length … “)”)
end[/lua]

Now you can do something like:[lua] ply:AddNotify(“UR A FAGET”, NOTIFY_GENERIC, 5)[/lua]

Although if it doesn’t work at first, just fiddle around with it a little, as SendLua is a piece of shit within itself.

Thanks ^^^^^^^^^^^^^^^^^^ :slight_smile:

Quick question, can I use the metatable for the player to do use it, like, plymeta:AddNotify(yada,yada,yada) ?

Have you tried


DarkRP.notify

?

I’m not sure if that exist’s but I’ll try!

[editline]11th September 2013[/editline]

Does not work. is not a thing.

Was referring to if you’re using the refactor branch.

Little new to GMod coding, I started coding GMod stuff like, 3 days ago. So what is the refactor branch?
Extremely sorry for the newbness.

The refactor branch is essentially DarkRP 2.5.0. FPtje is splitting the gamemode into Modules, and these modules can be “modified” using the DarkRPModification addon also made by FPtje
It can be found here
https://github.com/FPtje/DarkRP/tree/refactor

DarkRP Modification Addon

Ok then no, I’m not useing DarkRP:Notify, but i have the dark RP modification addon. So what do I do to get this to work now?