Addon files won't show in addons folder

Hello,

Garry’s Mod workshop files do not appear in the addons folder for some reason. I have tried reinstalling Garry’s Mod(Three times to be exact), Downloading Garry’s Mod on another computer and trying to see if they show up, switching to offline mode then back to online mode, unsubscribing from all gmod addons then resubscribing(Addons folder was empty prior to this), deleting all gmod files manually and then reinstalling, but nothing has worked.

This is what shows up in the console:


Failed to read addon 954519901!
--- Missing Vgui material vgui/servers/icon_replay
--- Missing Vgui material vgui/servers/icon_replay_column
Extraction failed.. Oh oh! (E:/( . ) ( . )/Program Files/Steam/steamapps/common/GarrysMod/garrysmod/addons/temple_with_collision_mod_[props]_by_neiremberg_954519901.gma)
END: DownloadAddons
Faied to read addon 1135113981!
Extraction failed.. Oh oh! (E:/dundun/Program Files/Steam/steamapps/common/GarrysMod/garrysmod/addons/roman_soldier_and_praetorian_[playermodel]_by_neiremberg_1135113981.gma)
END: DownloadAddons
Faied to read addon 1138026547!
Extraction failed.. Oh oh! (E:/dundun/Program Files/Steam/steamapps/common/GarrysMod/garrysmod/addons/payday_2_scarface_(ragdoll)_1138026547.gma)
END: DownloadAddons
Faied to read addon 1138414631!
Extraction failed.. Oh oh! (E:/dundun/Program Files/Steam/steamapps/common/GarrysMod/garrysmod/addons/hl2_quick_info_1138414631.gma)
END: DownloadAddons
Faied to read addon 903603949!
Extraction failed.. Oh oh! (E:/dundun/Program Files/Steam/steamapps/common/GarrysMod/garrysmod/addons/the_witcher_3_-_grandmaster_ursine_geralt_[pmnpc]_903603949.gma)
END: DownloadAddons
Addons have changes - remounting
Not loading addon 'addons/temple_with_collision_mod_[props]_by_neiremberg_954519901.gma' - file doesn't exist
Couldn't mount addon [Temple with Collision Mod [Props] by Neiremberg][addons/temple_with_collision_mod_[props]_by_neiremberg_954519901.gma]
Removing bad addon addons/temple_with_collision_mod_[props]_by_neiremberg_954519901.gma
Not loading addon 'addons/roman_soldier_and_praetorian_[playermodel]_by_neiremberg_1135113981.gma' - file doesn't exist
Couldn't mount addon [Roman Soldier and Praetorian [Playermodel] by Neiremberg][addons/roman_soldier_and_praetorian_[playermodel]_by_neiremberg_1135113981.gma]
Removing bad addon addons/roman_soldier_and_praetorian_[playermodel]_by_neiremberg_1135113981.gma
Not loading addon 'addons/payday_2_scarface_(ragdoll)_1138026547.gma' - file doesn't exist
Couldn't mount addon [PAYDAY 2 Scarface (Ragdoll)][addons/payday_2_scarface_(ragdoll)_1138026547.gma]
Removing bad addon addons/payday_2_scarface_(ragdoll)_1138026547.gma
Not loading addon 'addons/hl2_quick_info_1138414631.gma' - file doesn't exist
Couldn't mount addon [HL2 Quick Info][addons/hl2_quick_info_1138414631.gma]
Removing bad addon addons/hl2_quick_info_1138414631.gma
Not loading addon 'addons/the_witcher_3_-_grandmaster_ursine_geralt_[pmnpc]_903603949.gma' - file doesn't exist
Couldn't mount addon [The Witcher 3 - Grandmaster Ursine Geralt [PM/NPC]][addons/the_witcher_3_-_grandmaster_ursine_geralt_[pmnpc]_903603949.gma]
Removing bad addon addons/the_witcher_3_-_grandmaster_ursine_geralt_[pmnpc]_903603949.gma
PREP OK
Using map cycle file cfg/mapcycle.txt.
Nav File is wrong or something (4)


Any help would be appreciated

Hey,

I’ve been having this problem for a few days. I noticed nearly everyone with this problem was downloading to a secondary harddrive. I installed Gmod onto my C disk and it is working fine. It put all of the addons straight into the addons folder on first launch. Just a thought!