Addon, no suggestions have worked

I can not get any single addon to work, several things need to be established.

  1. There was no addon folder that the game came with, no not even in garrysmod/garrysmod.
  2. Making an addon folder did not help in any way.
  3. Placing the addons in garrysmod/garrysmod/materials didn’t work either.

Every topic just seems to say the same three things over and over again so I would really appreciate some help.

Take the folders and put them into garrysmod/garrysmod. if theres only an addon folder for the addon your wanting, open up the addon folder then open up the folder in that and put those folders into garrysmod/garrysmod. heres an example

Bob’s weapons
“addons/bob’s weapons/lua/weapons/bob’s mp5/shared.lua”

take the lua folder and put it in

“garrysmod/garrysmod”

it should end up like this

“garrysmod/garrysmod/lua/weapons/bob’s mp5/shared.lua”

If this doesn’t work then that means that 1 or more of your garrysmod core files are corrupted. Please tell me if this worked for you or not. If it did not then I will gladly show you how to fix garrysmod so you can be on your way

There are 3 options to choose from here.

  1. Contact garry (He will not respond to your messages)
  2. Keep trying new downloads. Some dont always work.
  3. Give up.

I tried what you said and when I went to paste it in it said that there was already a Lua, materials and a models file. It wanted to merge them but I figured that should be avoided so I renamed the addons files as LuaAS, MaterialsAS and ModelsAS (I downloaded an alien swarm pack), This did nothing, should I have merged the folders?

[editline]02:00PM[/editline]

Nope, merging didn’t work either.

if it says to overwrite the folder, you click yes because it will just simply take the files and put them into the folder without actually overwriting anything.

anyways if that doesn’t work here’s how to reset garrysmod

go into steamapps/“user”/garrysmod and delete the garrysmod folder in there (the second one)

then bring up steam and scroll down to garrysmod and click play. it will either update or immediately start playing. start up a map in singleplayer. You will notice that it is the default garrysmod.

Basicly what it does is garrysmod and steam have autofix programs and for garrysmod, its autofix will usually only remake the garrysmod folder if the folder is missing. When it remakes the folder, it is to how the folder is when first bought (does not work if you pirated garrysmod)

Like I said, merging/overwriting didn’t work either, I bought my gmod off steam so I don’t know why it didn’t have an addons folder. I just bought it yesterday so maybe the newer versions don’t have them?

[editline]11:45PM[/editline]

Alright, I eventually figured it out through trial and error, but thanks for your efforts.