Addonissimo! - Take control of your addons

[release]

http://dl.dropbox.com/u/256471/AddonissimoLogo.png

Have you ever wondered why you downloaded all of those addons? Haven’t you always wanted to keep them for later instead of having to delete them to speed up your game? Well here is your answer!

Addonissimo is a revolutionary addon that lets you control the loading of your addons in real time! By editing the Extensions menu included with every copy of Garry’s Mod, Addonissimo lets you control if you want to:

[ul]
[li]Load an addon only in singleplayer[/li][li]Load an addon only in multiplayer[/li][li]Not load an addon at all![/li][/ul]
Using a foolproof interface and installation, never again will you have to constantly move or delete your addons to keep your loading times down and your screen nice and clean!

In the recent release of version 1.3, a new profile system was added to greatly increase your selection of addons depending on a particular server or gamemode!

v1.42 Screenshot:
[img_thumb]http://ahb.me/oPm[/img_thumb]

Installation:
Simply open the zip file and drag the “garrysmod” folder into your 1st garrysmod folder (*/garrysmod/*garrysmod/), then click “Merge All” when asked.

:siren::siren::siren:


You are required to download the [the Visual C++ 2010 Runtime Package](http://www.microsoft.com/downloads/details.aspx?FamilyID=a7b7a05e-6de6-4d3a-a423-37bf0912db84&displaylang=en) in order to install! 

:siren::siren::siren:
:siren::siren::siren:


If you are using Windows Vista or Windows 7, make sure you've taken the steps to [Disable DEP for hl2.exe](http://ahb.me/oPr), as this can cause crashes.

:siren::siren::siren:

Special thanks to Polly/RaBBish and Chrisaster/Skondra!

Download V1.45 Now!
**
VIEW SOURCE**

If you like this, you could buy me a cookie, and I’d be very happy :3
http://accesstorec.org/img/PayPal_mark_50x33.gif[/release]

:iia:, I recommend it :v:

:golfclap:

I was waiting for something like this :h:

Source code?

Nice job Gbps. However, I don’t use many addons so I don’t think I will be needing this much.

In the zip.

-Whoops!-

I have this error ? any hint ?



Garry's Mod client.dll Build #087 [Jul  5 2010 10:12:48]
Lua: error loading module 'addonissimo' from file 'c:\program files (x86)\steam\steamapps\lotus006\garrysmod\garrysmod\lua\includes\modules\gm_addonissimo.dll':
	The specified module could not be found.


Uhm, check to make sure you have the Visual C++ Runtime files up to date.

[editline]12:18AM[/editline]

Otherwise I have no idea why you would get that.

Why the Icon of Addonissimo have a ++ in green on it ?

And this Visual C++ is good ? (I have Windows 7 x64 with an Acer 8942g)

http://www.microsoft.com/downloads/details.aspx?familyid=bd2a6171-e2d6-4230-b809-9a8d7548c1b6&displaylang=en

http://img337.imageshack.us/img337/275/addonissimo.png

Yes that one is good. The addonissimo icon is just like that, it’s not installed until you see the green checkmarks.

I tried with a fresh installation too but it’s not working too.
:frowning: Same error

I’ll take a look at it in the morning.

Nice job Gbps, I can always count on you to provide well made, useful addons :smile:

This just might be the best thing ever made.

[editline]02:24AM[/editline]

Wait, what do I have to do to get it to work? I put the folders where they belong, yet my extensions menu looks like it always has.

Post a paste bin of your console, there could be an error.

Also check to make sure lua/vgui/Addonissimo.lua exists.

Thank you for this :slight_smile:

Glad to help! :buddy:

Mounting hl2… OK
Mounting ep2… OK
Mounting tf… OK
Mounting cstrike… OK
Mounting dod… OK
Mounting episodic… OK
Mounting hl2mp… OK
Mounting portal… OK
Mounting lostcoast… OK
Mounting hl1… OK
Mounting hl1mp… OK
Mounting zeno_clash… No permission
KeyValues Error: LoadFromBuffer: missing { in file addons/Collector’s Armor/info.txt

KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file addons/RP-Pack/info.txt
AddonInfo,
Garry’s Mod server.dll Build #087 [Jul 1 2010 14:01:09]
maxplayers set to 128
Unknown command “sv_allow_wait_command”
Steam config directory: h:\steam\steamapps\mannehoe\garrysmod\platform\config
Parent cvar in server.dll not allowed (sv_scriptenforcer_initialkick)
Garry’s Mod client.dll Build #087 [Jul 5 2010 10:12:48]
Lua: error loading module ‘addonissimo’ from file ‘h:\steam\steamapps\mannehoe\garrysmod\garrysmod\lua\includes\modules\gm_addonissimo.dll’:
The specified module could not be found.

maxplayers set to 1
Unknown command “cl_thirdperson”
Unknown command “hud_showemptyweaponslots”
Unknown command “sv_backspeed”
GetAllManifestFiles: Unable to load maplist.txt

Aha, it doesn’t seem to find the module, yet it is there…

http://img441.imageshack.us/img441/2284/proofb.png

And there’s an Addonissimo.lua file in my lua/vgui/ folder

Ah, same problem as above. Unfortunately I’m away from my computer and it’s too late to fix it. I’ll be up in the morning and figure out the problem :slight_smile: